Updating Survey123 Connect

542
1
Jump to solution
05-16-2018 03:37 AM
JohnMcConalogue
New Contributor III

I have Survey123 connect version 1.10.43 and i am trying to upgrade it to a more recent version.

Every time I try to update it with a new version the upgrade runs fine but when I try to open the updated version I get the following error message:

"The program can't start because api-ms-win-crt-runtime-l1-0.dll is missing from your computer. Try re-installing the program to fix this problem."

Anyone know why I keep getting this?

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
JohnathanHasthorpe
Esri Regular Contributor

Hi John

Please see the following from the documentation (known issues) :

The Survey123 for ArcGIS field app fails to start, and an error message appears stating that the api-ms-win-crt-runtime-l1-1-0.dll file is missing.

This message indicates that the Universal C Runtime in Windows components, which are required for running Survey123, are missing. These components were distributed in a Windows update that can be downloaded from Windows support (https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows )

In most cases ensuring that you operating system is installed with the latest updates will resolve the issue.

Thanks
John

View solution in original post

0 Kudos
1 Reply
JohnathanHasthorpe
Esri Regular Contributor

Hi John

Please see the following from the documentation (known issues) :

The Survey123 for ArcGIS field app fails to start, and an error message appears stating that the api-ms-win-crt-runtime-l1-1-0.dll file is missing.

This message indicates that the Universal C Runtime in Windows components, which are required for running Survey123, are missing. These components were distributed in a Windows update that can be downloaded from Windows support (https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows )

In most cases ensuring that you operating system is installed with the latest updates will resolve the issue.

Thanks
John

View solution in original post

0 Kudos