TypeError: Cannot use 'in' operator to search for 'name' in

2397
12
Jump to solution
10-26-2022 08:39 AM
Comisión_Estatal_de_Aguasde_Qu
New Contributor II

Hi, I have a problem when i try to serch a value in the "filter" . The message is the next:

TypeError: Cannot use 'in' operator to search for 'name' in

Help!

Any ideas on this would be appreciated!

Note: Yesteday it worked ok.

Comisin_Estatal_de_Aguasde_Qu_0-1666798247456.png

 

 

1 Solution

Accepted Solutions
ZhifangWang
Esri Regular Contributor

Hi @Comisión_Estatal_de_Aguasde_Qu ,

Thanks for your feedback.

It seems to be the same issue with https://community.esri.com/t5/arcgis-survey123-questions/filtering-integers-broken-after-october-25-... , which is caused by any number value involved in the filter.

We are looking into the details and will evaluate a hotfix to address this.

 

Thanks,

Zhifang

View solution in original post

12 Replies
ZhifangWang
Esri Regular Contributor

Hi @Comisión_Estatal_de_Aguasde_Qu ,

Thanks for your feedback.

It seems to be the same issue with https://community.esri.com/t5/arcgis-survey123-questions/filtering-integers-broken-after-october-25-... , which is caused by any number value involved in the filter.

We are looking into the details and will evaluate a hotfix to address this.

 

Thanks,

Zhifang

Comisión_Estatal_de_Aguasde_Qu
New Contributor II

 

Thanks!!

GIS_Fox
Occasional Contributor III

Hi @ZhifangWang  and @Comisión_Estatal_de_Aguasde_Qu , 

We are expereincing the same type of TypeError on our S123 Form as of this morning. It is a web browser form non Survey123-Connect published, S123 version 3.16, with a repeatable error from using the Contains variable in filtering. Error message is as follows.

JansenLyons_0-1666801742442.png

Thanks,

 

 

Jansen Lyons - Records and GIS Section - Public Works - City of Rio Rancho, NM
JeffLegato1
Occasional Contributor

We are experiencing the same issue.  I found a workaround by setting the filter to be 
filter=(1.OBJECTID%20isBetween%20{OBJECTID|%20and%20{OBJECTID})

0 Kudos
GeomaticsAecon
New Contributor III

Any update on this?  ETA?  

DataOfficer
Occasional Contributor III

We are experiencing the same issue (see attached image). Worth noting that the filters I am trying to set do not involve numbers.

An error occurred while applying the filter.

TypeError: Cannot use 'in' operator to search for 'name' in [search term here]

 

0 Kudos
ZhifangWang
Esri Regular Contributor

Hi ALL,

The Survey123 Beta website https://survey123beta.arcgis.com has been updated with the fix to this issue. Can you please help test if the Beta website works for your workflow?

If everything looks good, we will deploy the fix to the production website on 10/31.

Maureen
New Contributor II

Works for us too.

0 Kudos
DiegoLlamasOlivares
Occasional Contributor

Hello Zhifang, 

using that url i do not have the error. 

regards,

 

DLL

0 Kudos