Time included in metadata start value?

1587
4
Jump to solution
02-08-2016 08:20 AM
TerryIffland
Occasional Contributor

I'm using the metadata value start to track the date and time when a survey is created as outlined in the post where, when, who is capturing data?  When I look at the data when a feature is created, only the date is available.  Is there an additional setting I need to make in the form so the time is available?

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
IsmaelChivite
Esri Frequent Contributor

Hi Terri,

the Show Time option is not enabled for all Date Formats. If you change the Date Format in the drop down list to 12/21/1997 for example, you will see the option enabled.

Ismael

View solution in original post

0 Kudos
4 Replies
IsmaelChivite
Esri Frequent Contributor

Hi Terri,

  technically, the Date data type in ArcGIS also includes the Time. So essentially, when you create a Date question in Survey123 for ArcGIS, both the Date and Time are persisted. When you add a Time question, the Date is also captured.   The trick is that by default, some clients such as the ArcGIS.com Map Viewer will only display the Date and hide the Time. Fortunately, it is relatively easy to change this and show the Time as well. In your Web Map, open the Configure Attributes window, select the Start field and pick a Format showing the Date as below. At that time, the Show Time option will be enabled.

Capture.PNG

0 Kudos
TerryIffland
Occasional Contributor

I saw this when investigating this issue. For some reason, though, I don't get the option to include the time.

ConfigAttributes.jpg

Just out of curiosity, is there any relationship to a specific version of ArcGIS Desktop that may reside on the same machine as is used to create the survey?  I have 10.1 on the same machine being used to create the survey.

0 Kudos
IsmaelChivite
Esri Frequent Contributor

Hi Terri,

the Show Time option is not enabled for all Date Formats. If you change the Date Format in the drop down list to 12/21/1997 for example, you will see the option enabled.

Ismael

View solution in original post

0 Kudos
TerryIffland
Occasional Contributor

I didn't know the time option wasn't available for all date options. When I switched to a different date format, the time became available for me.

Thanks! This resolves my issue.

0 Kudos