The custom feature service submission_url is not compatible with this survey

322
2
02-24-2023 12:55 PM
Eggnoggy1
New Contributor II

I am trying to create a survey built on an existing and hosted feature layer. I seem to be able to set it up in Excel, but when I try to publish I keep getting an error:

The custom feature service submission_url is not compatible with this survey. Fields not found in the feature service: 0.

My process is to open ArcGIS Survey123 Connect on my desktop. Click on + New Survey. Select Feature Services. Locate the feature layer, click on it, then click Create survey. I setup the Excel form, save it, it looks right in Survey123 Connect. But it never publishes. I keep getting that error.

I have checked Enable Editing and Enable Sync (required for offline use and collaboration) in settings in my feature layer. Also Public Data Collection is checked as well.

I also tried entering the name of the form and the form_title and the form_id in the settings tab in the Excel worksheet and no change.

Any ideas?

 

 

 

 

 

0 Kudos
2 Replies
ZacharySutherby
Esri Regular Contributor

Hello @Eggnoggy1

What version of Survey123 Connect are you using? If you are using 3.16 try updating to the latest 3.17 release of Survey123 Connect. 

https://apps.microsoft.com/store/detail/arcgis-survey123-connect/9PMST5C0DLST?hl=en-us&gl=us&rtc=1

https://www.esri.com/en-us/arcgis/products/arcgis-survey123/downloads

Thank you,
Zach
Eggnoggy1
New Contributor II

That was it, thanks.

0 Kudos