Survey123 web form issues in Safari browser

223
2
06-17-2020 02:40 AM
DataOfficer
Occasional Contributor III

We have a public Survey123 form published from Connect and completed via the web form (either directly on the Survey123 webform or as an embedded form on a webpage). A mac user has reported errors with the form when trying to complete it using Safari. They have been able to overcome this by using Chrome instead, but we would like to resolve it in case it affects other users.

The incorrect form behaviour appears to consist of the following issues:

  • the form not accepting entries to a question which has a choice filter
  • relevant questions dependent on the answer to the above choice filter question are therefore not displaying either.

It may or may not be relevant that these questions occur within a repeat.

As this is occurring with a public user, we have been unable to carry out much testing or gather as much detailed information as we could from our own staff. We have also been been unable to replicate the issue (only one colleague uses a mac and it performs correctly in Safari when they tested it - which could be down to specific OS or Safari versions). The mac it performed correctly on was running OS High Sierra and Safari version 13.1.1. The issues occurred on a mac running the High Sierra 10.13.5 operating system and Safari version 11.1.1.

0 Kudos
2 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Rob,

It would be helpful to file a support ticket with Esri to diagnose the issue.  That being said, you are using older versions of macOS; updating Safari (which may require upgrading macOS; the current version is 13.x) may resolve the issue.

DataOfficer
Occasional Contributor III

Hi James,

Thanks for the reply. I will log a case as suggested. I believe it may be associated to certain browser versions, but I have recently had the same issue reported from a public user on Android 10.

0 Kudos