survey123 new bug - non-required field is being required only in newest version of iOS app

515
3
Jump to solution
07-11-2019 03:54 PM
JakeJacobs
Occasional Contributor III

I have a survey which I've been using for a while in the iOS app.  When I updated to 3.5.164 Survey123 the other day, all of a sudden one question which is not required is being required by the app.  There's no red asterisk next to it and there is no validation logic, but the survey keeps returning to that question to require me to enter a value.  The field in the hosted feature service shows that it is nullable.


Users who have the previous version of the app are not seeing the behavior with the same exact survey.

I tried to republish the survey with the latest version of Survey123 Connect, but that did not change the behavior.

I tried to delete the app on my iPad and redownload the whole app, and that did not change the behavior.

The same behavior is present in the latest version of the preview window in the Survey123 Connect app on my Windows machine.

What's more, I can't spot the pattern that would make this question different from several others in the same survey.

I've attached the excel form that is driving the survey.  The only question that is exhibiting the behavior in the survey with the latest version is NUMANCHORRODS.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
JakeJacobs
Occasional Contributor III

This has been logged as a bug with ESRI

BUG-000123746
A non-required integer field with constraints is treated as a required field if there is a hidden field immediately after it

In my case, I had a non-required integer field with constraints (enter a number between 0 and 100). Then I had a hidden field that was used to calculate values for a choice filter, with the choice filter being used in the question below that.

I might add that the hidden field was not immediately below the non-required integer field. It was a couple rows below. 

My workaround will either be to remove the constraints (fairly low-risk data entry issue) but leave the constraint message, or to expose the hidden field as a read-only field, which looks weird but would then allow all the validation to work. 

View solution in original post

0 Kudos
3 Replies
JakeJacobs
Occasional Contributor III

I should add that the survey is currently published against an existing hosted feature service, which is in the configuration. So if you want to try it out for yourself, remove that parameter.

0 Kudos
JakeJacobs
Occasional Contributor III

This has been logged as a bug with ESRI

BUG-000123746
A non-required integer field with constraints is treated as a required field if there is a hidden field immediately after it

In my case, I had a non-required integer field with constraints (enter a number between 0 and 100). Then I had a hidden field that was used to calculate values for a choice filter, with the choice filter being used in the question below that.

I might add that the hidden field was not immediately below the non-required integer field. It was a couple rows below. 

My workaround will either be to remove the constraints (fairly low-risk data entry issue) but leave the constraint message, or to expose the hidden field as a read-only field, which looks weird but would then allow all the validation to work. 

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Just to conclude this, this BUG was addressed in the August 1 (3.5.176) release of Survey123.

0 Kudos