Survey123 - Merge existing data into a survey

1245
2
Jump to solution
02-15-2018 07:31 PM
JohnPlunkett
Esri Contributor

Hello -

Just checking that this is a valid workflow using survey123

Problem - User needed to make a change in the survey (change answer required to not required)

When attempting to republish this error message appears. (Survey name redacted)

Possible Solution

Create a new survey and publish it.

However we need the old results from the first survey

.

If the schema is the same in theory could we append the data to the new Feature Service that is created when we publish the new survey?

-Would these appeneded results appear in the analysis tab in Survey123 - granted the Edit dates/ submitted dates would be different

Are there other potential pitfalls that could happen

If there are any other ideas or workflows that I have not thought of feel free to add in comments

Cheers

1 Solution

Accepted Solutions
JohnathanHasthorpe
Esri Regular Contributor

Hi John

First of all making a question required/un-required should not prompt republishing of the service.

I note that the error message that it looks like there is an issue with the related table. Could share a bit information on the survey (or even better email it to me) and let me know if this an AGOL hosted service or otherwise, and I will try to replicate this.

In terms of your workaround - yes if the schema of the new survey/service matches the original survey/service you will be able to append the data to it and yes your will be able to see the appended data in the Analysis tab of the Survey123 Website.

Another approach would be to build a new survey based on the existing feature service. Take a look at the following resource: Use Survey123 with existing feature services—Survey123 for ArcGIS | ArcGIS .

It would be good to get a better understanding of your issue, as the change should not require a re-publishing. Please feel free to email me directly and we can troubleshoot this.

Thanks

John

View solution in original post

2 Replies
JohnathanHasthorpe
Esri Regular Contributor

Hi John

First of all making a question required/un-required should not prompt republishing of the service.

I note that the error message that it looks like there is an issue with the related table. Could share a bit information on the survey (or even better email it to me) and let me know if this an AGOL hosted service or otherwise, and I will try to replicate this.

In terms of your workaround - yes if the schema of the new survey/service matches the original survey/service you will be able to append the data to it and yes your will be able to see the appended data in the Analysis tab of the Survey123 Website.

Another approach would be to build a new survey based on the existing feature service. Take a look at the following resource: Use Survey123 with existing feature services—Survey123 for ArcGIS | ArcGIS .

It would be good to get a better understanding of your issue, as the change should not require a re-publishing. Please feel free to email me directly and we can troubleshoot this.

Thanks

John

View solution in original post

JohnPlunkett
Esri Contributor

They mentioned that the survey was created in a much earlier version of survey123 connect, sometime early 2017 and this was the first time they made a change

Anyhow  the customer I was working with

 

Exported the data in file geodatabase format, then made a test survey based on the existing feature service, pulled this service into ArcPro and simply appended the data into the service.  It seemed to work fine (including photos!). 

Reply
0 Kudos