Survey123, Integromat & Microsoft Office 2013 Outlook

360
4
02-20-2020 01:57 PM
JaredPilbeam2
MVP Regular Contributor

Hello,

Our organization uses Microsoft Office Professional Plus 2013 Outlook. I'm attempting to set up a simple email notification using Integromat. Integromat doesn't have a module for Office that I can see. So, I used the Office 365 Email module instead thinking this would work. I set the workflow up, hit Run Once and then submitted a survey. But, I'm getting a DataError. I sent the email to myself using my Outlook account. It seems to have a problem with this. The thing is, I was able to successfully set up a connection to Microsoft.

0 Kudos
4 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Jared,

This appears to be an issue with the Outlook Connector- do you have Office 365 Outlook (E-mail) enabled for your organization?

0 Kudos
JaredPilbeam2
MVP Regular Contributor

Hi James,

No, we do not use 365. We use Outlook 2013. I submitted a request for Outlook 2013 through Integromat's module search. They got back saying I could just use the Universal Email module to connect to Outlook Email. This is where I'm at now. Still getting errors. I'm not sure what the Connection name is. I've tried a few different things: SMTP server name, sign-in name, email, account name. I keep getting this error.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Jared,

As e-mail server configurations can differ from organization to organization, I would suggest working with your IT to get this configured correctly.

0 Kudos
JaredPilbeam2
MVP Regular Contributor

James,

I've started using the Send Emails geoprocessing tool instead. It's available from ServiceSupport.pyt toolbox.

More info here. Send email notifications - Crowdsource Reporter | ArcGIS Solutions for Local Government 

I've configured it to send an email based on survey submissions through Survey123 Connect.

0 Kudos