survey123 feature report date output different with users

166
8
08-07-2019 01:50 PM
Highlighted
New Contributor II

My department all uses the same same survey to capture photos and location data.  We also have identical templates used to generate reports.  If I generate a feature report from my coworkers survey the date in the heading is the date she took the survey which is what we want.  But when she generates a feature report using the same data from Survey123 online, and clicking the same uploaded template, the final result uses today's date, not the date the photos were taken.  How can we be getting two different results using the same data from the same place and the same uploaded template?  

Thank you!

Reply
0 Kudos
8 Replies
Highlighted
New Contributor III

Best guess, I would be looking for something with a now() function.

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Zach,

Could you share the template?  As you suggest, they should be creating the same information, regardless of who submits the request.

Reply
0 Kudos
Highlighted
New Contributor II

Reply
0 Kudos
Highlighted
New Contributor II

Reply
0 Kudos
Highlighted
New Contributor II

I want the date in the heading to be the date that the photos were taken, that's why I have the hidden< adate< Date field in the Excel Spreadsheet. I just don't know how the report could be different when we run the same survey data, using the same template, on two different machines. Thanks again for all your help!

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Zach,

Thanks for the additional information.  In looking at this, you should not be seeing different dates.  

In you Excel sheet, is the hidden question have the bind::esri:FieldType set to 'EsriFieldTypeDate'?  Otherwise, the date field will be stored as a string. In your case, you may want it stored as a string representation anyway.

Reply
0 Kudos
Highlighted
New Contributor II

Thank you for following up James, here is what I currently have it set as. 

Reply
0 Kudos
Highlighted
New Contributor II

Hi James,

Any chance you looked at my last screenshot?  Still don't know why it's happening.

Best,

Zach

Reply
0 Kudos