Survey123 export data function not working

624
3
12-09-2019 03:18 AM
CharlesDexter
New Contributor

Hello, 

I recently tried to download a number of data sets (36) in to excel using the Export function, this just displayed the working export title, I left it for a while and nothing happened. Assuming this was a problem with the number and size of data sets I tried on another survey which i had exported from before a number of times, the same issue, it seems that I can no longer export data from the surveys.

Is anyone else having this problem?

Thanks

Charles 

0 Kudos
3 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Charles,

Can I ask that you go to your ArcGIS Online account's My Content section ad try to export from the feature layer item details page of your survey?  The SUrvey123 export function uses this feature - I want to make sure that is functioning correctly.

0 Kudos
CharlesDexter
New Contributor

Hi James,

Yes in the my content section the excel list has outputted correctly. I have tried again to output the data directly from Survey123 export function and it now looks like it is working ok again so I don't know why that happened.

Thanks

Charles

0 Kudos
AndyVenuto
New Contributor

Yes. We were having the same issue. The export function was not working for non-administrator users as you mentioned above(export grays out and just spins). However, the download function was still working for administrators. We discovered that the stakeholder view feeds the user Data tab on the Survey123 console page, rather than the main feature service. This stakeholder view had a definition set that restricted data by date. Once we removed the definition date filter, the download worked normally again. Hope this helps.

Thanks

Andy

0 Kudos