Survey123 Dropdown Not Appearing in MS Edge Browser

1361
9
06-18-2021 09:13 AM
ClaireC
New Contributor II

Hello, 

We have a link to a Survey123 form in an arcGIS Hub site. When this form is accessed using Microsoft Edge (Version 91.0.864.53) the dropdown options appear to be disabled. The dropdown arrow appears to be greyed out. 

ClaireC_2-1624032520853.png

If I start typing in a species, the relevant options will populate but I cannot see the entire list.

ClaireC_3-1624032731358.png

 

The form works fine on other web browsers e.g. Chrome 

ClaireC_1-1624032385814.png

The other elements on the form (radio buttons, date pickers etc.) are all working fine in Edge. 

Any help on this matter would be greatly appreciated.

Many thanks, 

Claire

Tags (1)
9 Replies
IsmaelChivite
Esri Notable Contributor

Thanks for reporting. Can you send a link to the form?  I am guessing this behavior only happens when you enable autocomplete. Can you confirm?

0 Kudos
JulietK
Occasional Contributor II

Hi Ismael, I'm having a similar problem with Microsoft Edge Version 91.0.864.54 (Official build) (64-bit). 

In one survey I have 6 select_one_from_file fields. 2 of them contain geopoint data, all of them are autocomplete.

One of the select_one_from_file fields (one that contains geopoint) dropdown is working fine. But all other 5 are not working - the field is there, the arrow is there but when I click on the field rectangle, the dropdown list doesnt appear. However, unlike ClaireC's example, my fields are not greyed out. 

My non-external select_one fields that direct to my xlsform's choices tab work as normal.

 

I've tested your question with a test survey - with a select_one_from_file field, if I change the appearance to 'minimal compact' from autocomplete, the field seems to work as normal. 

JulietK
Occasional Contributor II

Additionally, the one select_one_from_file dropdown field that does work as normal on Edge with appearance 'autocomplete' is the only one csv file out of all my external csv's that has less than 20 rows. 

I also had a colleague test her survey with an autocomplete select_one_from_file field - her file has approx 18 rows and her field is working fine.

0 Kudos
ClaireC
New Contributor II

Hi Ismael, 

Thanks for the response. Unfortunately the survey is not public, but perhaps this is not just confined to our specific survey if JulietK is experiencing similar on Edge.

Yes, autocomplete is enabled. Changing to minimal compact does not really suit in this situation as there are 70+ options to chose from and having to navigate such a long list is not very user-friendly. 

Thanks, 

Claire

0 Kudos
AaronNash__GISP
New Contributor III
AaronNash__GISP
New Contributor III

I am having this same issue, dropdown is not working in edge, but works in Chrome correctly. 

0 Kudos
ClaireC
New Contributor II

Hi All, 

Has anyone found a solution or workaround for the issue?

Many thanks, 

Claire

0 Kudos
IsmaelChivite
Esri Notable Contributor

Hi @ClaireC  @AaronNash__GISP  and @JulietK  Sorry for the belated response. The team is looking at this. We will post a note here as soon as we have something to share. Thanks for sharing the link too! 

0 Kudos
AaronNash__GISP
New Contributor III

Hi, has there been any update on this? thanks

0 Kudos