Survey123 doesn´t run in some devices

1253
4
Jump to solution
07-26-2019 03:23 AM
José_CarlosPalma_García
New Contributor II

Hello,

I just updated survey123 (v. 3.5.164) in my tablet HUAWEI MEDIAPAD M2 10.0 and the app no longer run. Until the update was runnig ok.

I've the same version in a samsung galaxy tab2 and runs perfectly.

I've tried to install Survey123 Classic but the survey doesn´t work as expected. I´ve to work with the latest version.

¿Can you help me?

Thanks and regards

0 Kudos
1 Solution

Accepted Solutions
by Anonymous User
Not applicable

Hi Jose,

Can you confirm what version of Android is running on the HUAWEI MEDIAPAD M2 10.0? Is it Android 5.0/5.1?

There is a known issue with Android 5.0/5.1 with the latest Survey123 3.5 builds from the Google Play store. We now support a 64-bit Android build and the Google Play store will automatically try to install the the 64-bit build if the device is 64-bit, if the device is not 64-bit then the 32-bit version is installed. The Play store manages this automatically. However we have found with some older devices and devices running Android 5.0/5.1, there appears to be a SSL library issue where the app can not find some key dependencies.

This issue has already been fixed for the next Survey123 3.6 release and Google Play store update (due to be released in September). In the meantime, you will need to install the 32-bit Android version on the devices that are not currently working.

You can find the 32-bit Android version on the Survey123 website for download, and then you can install by manually copying it to the device. You can find the download link for the 32-bit Android version under the field app section on this page: https://www.esri.com/en-us/arcgis/products/survey123/resources

Note that Classic is no longer supported and should not be used as it does not include many fixes and improvements made to the app over the past 12 months.

Regards,

Phil.

View solution in original post

4 Replies
by Anonymous User
Not applicable

Hi Jose,

Can you confirm what version of Android is running on the HUAWEI MEDIAPAD M2 10.0? Is it Android 5.0/5.1?

There is a known issue with Android 5.0/5.1 with the latest Survey123 3.5 builds from the Google Play store. We now support a 64-bit Android build and the Google Play store will automatically try to install the the 64-bit build if the device is 64-bit, if the device is not 64-bit then the 32-bit version is installed. The Play store manages this automatically. However we have found with some older devices and devices running Android 5.0/5.1, there appears to be a SSL library issue where the app can not find some key dependencies.

This issue has already been fixed for the next Survey123 3.6 release and Google Play store update (due to be released in September). In the meantime, you will need to install the 32-bit Android version on the devices that are not currently working.

You can find the 32-bit Android version on the Survey123 website for download, and then you can install by manually copying it to the device. You can find the download link for the 32-bit Android version under the field app section on this page: https://www.esri.com/en-us/arcgis/products/survey123/resources

Note that Classic is no longer supported and should not be used as it does not include many fixes and improvements made to the app over the past 12 months.

Regards,

Phil.

José_CarlosPalma_García
New Contributor II

Hi! we have installed the 32 bit Android version of Survey123 and It's going well on Android 5.1.1!

Thanks and regards Phil.

by Anonymous User
Not applicable

Hi Jose,

Great, glad it worked and thanks for letting me know. Once 3.6 is released to the Google Play store, you will be able to install directly from the store again.

Phil.

0 Kudos
GISTEAM10
New Contributor

Hello Philip, I this solution still applicable to android 50./5.1. I am tryin to use that approach but it cant help. Please advise

0 Kudos