Survey123 crashes on iOS devices

382
8
04-18-2019 08:22 AM
Highlighted
New Contributor III

My survey crashes the Survey123 app anytime it is opened on any iOS devices. I have read issues with repeats type questions and iOS, but my survey does not have any repeats. See attached xlsform.

Tags (3)
Reply
0 Kudos
8 Replies
Highlighted
Frequent Contributor II

As a test delete all your relevants and see if it still crashes.  This was happening to me because I was hiding 10 fields that were large select_one lists.  I could hide like 6 - then at 7 it would crash.  I had to unhide some until it stopped crashing.

Just a guess since your form is huge.  You may want to consider putting the 1-8 sections in a repeat if your schema allows.

Reply
0 Kudos
Highlighted
New Contributor III

Thanks Doug. It does seem like the size of the form has something to do with it. I deleted all relevants, but it still crashes. I tried deleting the second 1-8 section to bring the total lines from 330 to 200(keeping relevants), still crashes. 

Reply
0 Kudos
Highlighted
New Contributor II

I am having a similar problem, whereby the survey (created with Survey123 Connect 3.3.51) works on my laptop (lenovo Windows) but crashes at certain questions within the survey when trying to use it on an iPad.  I have been able to add 54 records with a windows machine but can not add one record with iOS iPad to the same survey.

Survey123 Field app 3.3.64

I have removed the Repeat_Count references as mentioned in other posts, republished and it is still crashing on iOS.

suggestions?

Reply
0 Kudos
Highlighted
Frequent Contributor II

Are you hiding (via relevant) a bunch of big lists?  That was what it was for me.  I had to unhide 4 of my 7 to get it to stop crashing.

Reply
0 Kudos
Highlighted
New Contributor III

I finally got this working, it involved changing the esrifieldtypebind from time to null for one of the questions

Reply
0 Kudos
Highlighted
New Contributor II

Yes still happening for me, it seems that it has something to do with size or how much is hidden by relevant statements.  I get the survey working and then add a section or a couple of questions then it crashes again.  

Reply
0 Kudos
Highlighted
Frequent Contributor II

Have you tested the latest 3.6 one.  Seems much better on memory for me so far.

For sure the amount of stuff hiding was it for me too.  Esp big drop down lists.

Reply
0 Kudos
Highlighted
New Contributor II

I will look into that as still having issues with it.

Thanks for the tip.

Jed

Best regards

––––––––––––––––––––––––––––––––

Jed Jackson, BSc, ADIP-GIS, CGS

GIS Analyst

Mowi Canada West

––––––––––––––––––––––––––––––––

Mobile: (250) 202-4488

Mail: Jed.Jackson@mowi.com<mailto:Jed.Jackson@mowi.com>

Reply
0 Kudos