Select to view content in your preferred language

Survey123 Connect Freezes

1577
4
Jump to solution
08-12-2021 11:41 AM
RGrant
by
New Contributor II

I have a few surveys that were deployed from ArcGIS Online solutions that whenever I open them in Connect, they freeze connect within seconds. These are all edited versions of the "Citizen Problem Reporter" survey. Everything was working until I edited a field name, which was reverted but still is causing major freezing issues. I attached the form below to see if the error might be in the form. 

1 Solution

Accepted Solutions
by Anonymous User
Not applicable

Hi @RGrant,

Can you please confirm what version of Survey123 Connect you are using, and on what OS version?

I tested your XLSForm from creating new survey from Connect 3.12 and it appears to be working fine. It sounds as though there is an issue between the files locally in your connect and the feature layer information, giving you changed/renamed a field in the feature layer.

It may be best to create the survey again as new, and point it to the existing feature service again.

Regards,

Phil.

View solution in original post

0 Kudos
4 Replies
by Anonymous User
Not applicable

Hi @RGrant,

Can you please confirm what version of Survey123 Connect you are using, and on what OS version?

I tested your XLSForm from creating new survey from Connect 3.12 and it appears to be working fine. It sounds as though there is an issue between the files locally in your connect and the feature layer information, giving you changed/renamed a field in the feature layer.

It may be best to create the survey again as new, and point it to the existing feature service again.

Regards,

Phil.

0 Kudos
RGrant
by
New Contributor II

I was originally using 3.10 but updated to 3.12 yesterday and was still having the same issue. The issue persists for a few hours but then stopped and didn't return.

0 Kudos
by Anonymous User
Not applicable

Hi @RGrant,

So after upgrading to latest it sounds like the issue is fixed now, even though it occured for a few hours, it then stopped andnow works fine. Please let us know if it happens again.

Regards,

Phil.

0 Kudos
ColForbin
Occasional Contributor

This is happening a lot to me, I'd say maybe 50% of the time I save the XLS form, Connect freezes and I have to end the task in windows task manager.  I have a few pulldata calculations in there and reverse geocoding of geopoint question, and 10 choices.  I am using version 3.18.124.  Has there been a resolution to this?

0 Kudos