Select to view content in your preferred language

Survey123 Connect App Question

555
3
Jump to solution
03-13-2023 11:04 AM
jbrower
New Contributor II

Hi everyone, I need a bit of help completing this last portion of my survey. Using Survey123 Connect Version 3.15.175 and Enterprise 11. 

So I'm using a select multiple list to have certain textboxes appear when they select certain answers. The web app appears to do exactly what I want, only show certain boxes when certain answers are selected. But for the app, even when nothing is selected the boxes are still there. The excel is an example but directly copied from the format I have in Survey123 Connect currently. 

I'm using the integer type and using selected(${column_viol_type}, "violation1") in the relevant column.

The select multiple is select_multiple violations, and the type has 13 different answers to select from. 

Any help would be greatly appreciated. 

0 Kudos
1 Solution

Accepted Solutions
abureaux
MVP Regular Contributor

What you have should work:

abureaux_0-1678807975138.png

 

You should update your appearances though. 'horizontal' and 'compact' don't work together and are redundant.

You may or may not need the w1. The 'issue' I believe you are having is that on the 'settings' page you have set the 'style' to 'fixed-grid'. With fixed-grid set, all your hidden fields will still take up space. If you really want to use a grid, then 'dynamic-grid' will be what you want in this case.

View solution in original post

0 Kudos
3 Replies
Richard_Purkis
Esri Contributor

Hi @jbrower 

May  you test using the latest version of Connect. I can't recreate the issue you are seeing in the Field App.

violation.JPG

 

 

 

If the issue does still occur may you create a test survey using the form I provided and confirm if the issue still occurs for you

Thanks

0 Kudos
abureaux
MVP Regular Contributor

What you have should work:

abureaux_0-1678807975138.png

 

You should update your appearances though. 'horizontal' and 'compact' don't work together and are redundant.

You may or may not need the w1. The 'issue' I believe you are having is that on the 'settings' page you have set the 'style' to 'fixed-grid'. With fixed-grid set, all your hidden fields will still take up space. If you really want to use a grid, then 'dynamic-grid' will be what you want in this case.

0 Kudos
jbrower
New Contributor II

Changing it to dynamic-grid in the settings helped. Thank you so much!

0 Kudos