Survey123 Connect and Web designer sync issue

795
7
Jump to solution
06-19-2017 05:26 PM
GWTurner
New Contributor II

I created a form in S123Web designer. After accessing it from S123Connect, I was no longer able to edit the form from the website and it lost its browser functionality. It took me hours to create that form and as of now, I have to start from scratch and recreate it. Has anyone else had this issue?

0 Kudos
1 Solution

Accepted Solutions
JamesTedrick
Esri Esteemed Contributor

Hi GW,

Once a survey is altered by Survey123 Connect, the survey may have features that the current web designer and web form may not support, such as calculated fields.  If you want the survey to be filled in over the web, there is a next generation web form under development and accessible through Survey123 Connect - click on the globe icon when the form is loaded and selects 'Open in Survey123 web app'

View solution in original post

7 Replies
JamesTedrick
Esri Esteemed Contributor

Hi GW,

Once a survey is altered by Survey123 Connect, the survey may have features that the current web designer and web form may not support, such as calculated fields.  If you want the survey to be filled in over the web, there is a next generation web form under development and accessible through Survey123 Connect - click on the globe icon when the form is loaded and selects 'Open in Survey123 web app'

View solution in original post

PaulHoefflerGISS
Occasional Contributor II

I'm not seeing this captured in the Survey123 documentation - is this limitation still the case, and is it documented?

Thank you.

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi Paul,

Surveys created or edited via Connect that were originally created in Web Designer can not be edited in Web Designer after being modified by Connect. This is by design as not all features and supported configuration in Connect and supported in Web Designer, so it would not be possible to re-open and publish the survey again from Web Designer.

I have created a documentation issue to better explain this in the documentation for both Connect and Web Designer under Create Surveys.

Phil.

PaulHoefflerGISS
Occasional Contributor II

Hi Phil,

Thanks for confirming that this is still the case. I'm working with a user who did not expect this, hence the question about whether or not it's documented. I'm glad James Tedrick‌ captured it here and hope that it finds its way into one or more relevant locations in the online documentation with the issue you logged.

Thanks again!

Paul

0 Kudos
PaulHoefflerGISS
Occasional Contributor II

Philip Wilson‌, any updates on the documentation issue status?

As I understand it these are Esri-internal and there's no mechanism for us to track those.

Thanks! Paul

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi Paul,

Yes, the documentation was updated in 3.6 with a caution in the "Update Surveys" section in "Publish you survey" page. Here is the link: Publish your survey—Survey123 for ArcGIS | Documentation 

Phil.

PaulHoefflerGISS
Occasional Contributor II

Excellent, thanks for getting that updated and for the reference!

Paul