Survey123 'bearing' won't save in drafts

84
1
05-11-2021 11:20 AM
Blake_Munshell
New Contributor

Hello, 

I am working on a Survey123 form that requires users collecting data, and submitting it all at once when they return to their office due to lack of cellular data. The app works nearly perfectly, except for the 'bearing' question. It pulls up a compass, and the user will point the top of their device towards a field to indicate the bearing of the photo they take. This works if they submit the form immediately, but if they save the form as a draft, and complete it later, they value for bearing is not saved. 

The form is set up as follows: 

type: decimal, name: bearing, required: yes, label::English: Field Bearing, [other language labels], appearance: bearing

The other option we would have is pulling the EXIF data from the image they take, but the forced portrait perspective on the field app image capture gets complicated when calculating the correct orientation and is not desirable. 

Any ideas? Thanks. 

0 Kudos
1 Reply
BrettStokes
Esri Contributor

Hi @Blake_Munshell ,

Since the 'bearing' appearance is not yet supported in Survey123 this post would probably be better placed in the Early Adopter forums (for beta features). Having said that, I'm not able to reproduce the behavior you mention. Although I have noticed that when retrieving a survey from the Drafts folder, the decimal value is maintained in the data but not shown on the compass user interface. I've linked this post to our compass development issue.

Can you please confirm if the bearing value is actually being stored, but not shown on the compass (as I'm observing), or if indeed the bearing value is lost when submitting a survey from the Draft / Outbox folders?

Thanks,

Brett

0 Kudos