Survey123 adding a comma to calculated decimal fields

729
2
Jump to solution
02-27-2020 03:15 AM
Mondi_GIS
Occasional Contributor

We are struggling with Survey123connect and the Survey123 app adding a comma as the decimal separator to decimal fields when it calculates a value or pulls it through from another field. 

My PC regional settings are set to US (originally South Africa, but I changed these in case it made a difference). My  separator for decimals and currency is set to a decimal point. Excel is set to use a point as the decimal separator too. 

When I type into Survey123 decimal field it allows the decimal point: 

When it has calculated the field it uses a comma, and gives an error:

When I have a calculated field using the first example, the calculation does not work and returns a null when I have a decimal point in place. It is expecting a comma. It does not allow me to enter a comma however, as the decimal separator is a point. 

It works on the web app, but we need this to work on mobile/offline. Changing all users regional settings to comma is not an option. 

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
IsmaelChivite
Esri Notable Contributor

Hi. I was not able to reproduce this behavior with standard US configuration. It is likely that the regional configuration in your computer is different. See the animation below. I am attaching the XLSForm I used.  Can you compare the regional settings and see if there are any differences?

View solution in original post

0 Kudos
2 Replies
IsmaelChivite
Esri Notable Contributor

Hi. I was not able to reproduce this behavior with standard US configuration. It is likely that the regional configuration in your computer is different. See the animation below. I am attaching the XLSForm I used.  Can you compare the regional settings and see if there are any differences?

0 Kudos
Mondi_GIS
Occasional Contributor

Hi Ismael,

So I changed my settings to exactly what you have their, and now it is working (but now I have to suffer through American spelling in all my other documents. 

So, firstly, these were the settings that I had:

 

So, it would seem that somewhere Survey123 is ignoring the fact that we changed the default South Africa setting (which is is a comma decimal separator) to a point. 

Then, we made the same changes to my colleague's pc, but he did not have the US language pack installed, and so the changes did not work.  

t. 

0 Kudos