Survey123 3.16.113 update makes Inbox updates null for select ones with esri field bind to integer

674
2
Jump to solution
12-08-2022 10:30 PM
ChristopherCounsell
MVP Regular Contributor

We have a survey with select_one questions and an esri fieldtype bind of integer (or small integer). The survey responses are edited via the field app inbox. After updating the survey123 field app to 3.16.113 these questions are populated in the Inbox, not changed, but when submitted, change to Null in the feature service. Works fine in 3.15.xx (values remain populated after submission)

  1. Publish attached survey with Inbox and editing enabled
  2. Submit records with values in the questions
  3. Open the survey responses via the inbox. Note the values in the form. Submit without changing the responses. Reload the inbox. Note the values have gone null.

We believe the updates around 'BUG-000151353' in version 3.16.113 may have changed the way these values are handled. 

We don't need the values as integer within the survey form itself (XLSForm bind and calculations not relevant) but do need to retain these values as integer in the feature service.

@IsmaelChivite is this an intentional change?

0 Kudos
1 Solution

Accepted Solutions
ZacharySutherby
Esri Regular Contributor

Hello @ChristopherCounsell

Are you originally submitting with "No" selected then switching to "Yes" in the Inbox? If so we have the issue where choices with 0 set as the choice name are nulling out on submission reported, please see this thread for more information. I have tested with the XLSForm passed along selecting "No" submitting > reloading in the Inbox, make no changes, resubmit with "No" still selected for all the choices and the values remain. 

Thank you,
Zach

View solution in original post

2 Replies
ZacharySutherby
Esri Regular Contributor

Hello @ChristopherCounsell

Are you originally submitting with "No" selected then switching to "Yes" in the Inbox? If so we have the issue where choices with 0 set as the choice name are nulling out on submission reported, please see this thread for more information. I have tested with the XLSForm passed along selecting "No" submitting > reloading in the Inbox, make no changes, resubmit with "No" still selected for all the choices and the values remain. 

Thank you,
Zach
ChristopherCounsell
MVP Regular Contributor

Thanks, that appears to be it. Will chase the bug number

0 Kudos