Survey shows "JavaScript functions disabled" despite users both belonging to same organization

1316
2
Jump to solution
04-20-2022 09:38 AM
NASAHarvest
New Contributor

Hi!

We have two accounts that are trying to use the same survey. This survey uses a JS script that is attached to the form. However, when the second account tries to access the form, the survey is populated with a "JavaScript functions disabled". I know that this is for security reasons, that the user needs to be in the same organization as the creator of the JS function. 

They are both part of the same University of Maryland organization, both in uofmd.maps.arcgis.com. The survey is shared with the organization, and also with a group of which both accounts are members. 

Creator account: 

NASAHarvest_0-1650470591815.png

Collector Account: 

NASAHarvest_1-1650470675205.png

As you can see above, it is the same URL, same Subscription ID, same administrators, and different accounts. 

Is there something else I am missing that would prevent a JS function from being called in the Collector account? I can confirm the function works and everything when logged into the creator's account. Maybe a setting somewhere? 

Thanks. 

 

Edit: Ends up, the end user was not logged in to the correct account. Once they logged on to the correct account, they were able to see the correct JS display. 

0 Kudos
1 Solution

Accepted Solutions
IsmaelChivite
Esri Notable Contributor

This has been resolved: The end user was not logged-in when using the survey. Once the user logged-in the JS function executed as expected.

View solution in original post

0 Kudos
2 Replies
ZacharySutherby
Esri Regular Contributor

Hello @NASAHarvest

Are you taking the survey in the Survey123 field app or the Survey123 web app? 

Thank you,
Zach
0 Kudos
IsmaelChivite
Esri Notable Contributor

This has been resolved: The end user was not logged-in when using the survey. Once the user logged-in the JS function executed as expected.

0 Kudos