Survey's Results are Public

415
2
11-19-2019 04:24 PM
MatthewBradbury
New Contributor III

Is there a way to have ArcGIS Online honor the Viewer settings from a survey in Survey123?

We have created a public survey, and have shared it on our website. The settings for viewers in the survey says that only certain groups in our organization can view the results, but that everyone can submit, including the public.

When we search for the layer in ArcGIS Pro while logged into a user from another organization or a user who is not in a viewer group, we can search for and find the fieldworker layer (a hosted view), and when adding it to a map, while the points do not display, we can view all of the attribute table data from the survey.

We do not want anyone outside of the specified viewer groups to be able to see this data, but we also want the public to be able to submit records to the survey.

0 Kudos
2 Replies
BrandonArmstrong
Esri Regular Contributor

Hi Matthew,

Have you seen the following Blog? https://community.esri.com/groups/survey123/blog/2016/11/10/getting-started-with-public-surveys 

Of particular interest, might be the following sections...

  1. Log into ArcGIS Online using the credentials used to publish your public survey
  2. Go to the My Contents tab and open the folder corresponding to your survey
  3. Open the Item Details page of your Form
  4. Look for the Layers section within the Item  Details Page and click on the link. This will take  you to the Form's feature layer Item Details Page.
  5. Within your Feature Layer's Item Details  Page, select the Settings tab to change the editing privileges as you see fit for your needs.

 

 

Particularly in cases where your survey data is sensitive, you will want to select the option "Editors can't see any features, even those they add". In this manner, malicious users will not be able to download or query data from your surveys feature layer.

Is the desired behavior reflected after applying the mentioned settings to the Form Item?

Best,

Brandon

0 Kudos
MatthewBradbury
New Contributor III

That seems to have worked. I checked it in an AGOL search, and did still find the hosted view listed, but when adding it to the map, none of the records show up. I wasn't aware that the Field Worker settings were different than that of the Shareholder and the hosted feature layer. This setting really should be in the configuration for the surveys.

0 Kudos