Survey 123 Web - Unable to share survey results

317
7
10-21-2019 10:34 AM
JanPindroch2
New Contributor

Good morning,

I think something recently changed because this was working fine a couple weeks ago. 

I have a survey that I published using Survey123 Connect for ArcGIS 3.6. This survey is using already existing feature service that was published earlier using ArcMap. Users are able to submit their answers and everything works fine, but when I try to click 'Save' on this window:

I am getting this error message:

It creates this hosted feature layer that does not have any data:

After, hitting a 'Save' button second time I am presented with this error message:

I would like to share results, so users can view their submitted data.

Set-up: Portal for ArcGIS 10.7.1

Thank you for your help.

0 Kudos
7 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Jan,

Given the error code, there appears to be something wrong with the creation process of the stakeholder view.  Are you able to create a feature layer view for a layer outside of the survey123 website (such as the 'Item Details' page for a feature layer)?  I would suggest opening a support ticket with Esri Support to investigate further.

0 Kudos
JanPindroch2
New Contributor

Hello James,

Thank you for your reply. Unfortunately, I do not have an option to create a feature layer view. I only have these options:

I tried to manually create a hosted feature layer using:

It created a hosted feature layer, but this layer also didn't have any data. I guess you would assume to see all already existing data correct?

Thank you!

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Jan,

A few questions to diagnose:

- Is this service tied to an enterprise geodatabase?  

- Could you provide the url of the service (in particular, the part from /<webadaptor>/rest/... onward - the server name is not needed).  

- In the survey's folder, are there any feature layers with '_stakeholder' in the name?

0 Kudos
JanPindroch2
New Contributor

Hello James,

1. Yes. This service is tied to an enterprise geodatabase. We use SDE tables of this feature class for automatic export to another software that is used by foresters.

2. /arcgis/rest/services/Log_Quality/FeatureServer

I am not sure if you are able to access it. I can always contact esri Canada staff that is providing support to our company (?)

3. There are currently no '_stakeholder' layers in the survey's folder (I deleted them manually because they were empty).

Anyways, thank you very much for your help.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Jan,

If the service is tied to an enterprise geodatabase, then a hosted view cannot be created.  What's unusual is that the Survey123 website should not be trying to make the stakeholder view in the first place.  Could you work with Esri Canada to create a support incident for this?

0 Kudos
JanPindroch2
New Contributor

Hello James,

Yes, I can definitely do that. Thank you very much for all your help.

0 Kudos
DiegoLlamasOlivares
New Contributor III

Hello @JamesTedrick 

we are having this same error. When we select a group who can see data in survey123 online, using a hosted feature service. When we save the share option selecting a group we get this error

MicrosoftTeams-image.png

what could this be.

 

Thanks,

Diego Llamas

0 Kudos