Survey 123 mobile wont show negative numbers

518
5
Jump to solution
04-17-2023 05:07 AM
AntonioBrcković
New Contributor II

Hello,

I have an issue with the mobile Survey123 app.

I made a simple survey that allows me to keep track of the amount of equipment and it works on the computer and in the Connect app. But when I want to enter negative values in the mobile app (i.e. quantity_out) the stock field always shows a positive value. If I enter, for example, quantity_in=5 and quantity_out=3, the stock will be 2. But if I enter  quantity_in=3 and quantity_out =5, the stock will still show 2 and not -2.

Has anyone had a similar issue or have any ideas on how to troubleshoot?

0 Kudos
1 Solution

Accepted Solutions
BarbaraWebster1
Esri Regular Contributor

Hi @AntonioBrcković, thanks for the additional information. I can see the same behavior if I change the locale of my device to Croatian. Can you confirm whether the devices that are not displaying correctly are set to Croatian and that the ones that are displaying correctly are set to English or another language?

This seems to be a localization issue, and I'm creating an internal issue so the Survey123 team can take a look.

The issue looks to be specific to integers, so a workaround for this survey could be to change the bind::type for the quantity_stock question from int to decimal. 

View solution in original post

5 Replies
BarbaraWebster1
Esri Regular Contributor

Hi @AntonioBrcković,

I tried out the workflow you described in the field app (3.17.68) on an iOS and Android device and didn't see the same issue. Here are a few questions:

- Are you editing a previously-existing survey record in the inbox or are you seeing this for a newly-created survey?
- What version of the field app are you using?
- What is the model of the mobile device you're using?
- If you are able to share a screen cap or two of what you're seeing that might be helpful too.

Thanks,
-Barbara


0 Kudos
AntonioBrcković
New Contributor II

- I tried both, editing a previously-existing survey record and a newly-created survey and still got the same issue. 

- I am using the 3.17.68 version as are all of my colleges (7 have the same issue and 2 have no issue at all)

- The phones we are using are mostly Samsungs (A52S or A54) and it doesn't work on those devices,  but it works on a Samsung S21 and on a Huawei P30

Im sending 2 screen captures1 from the A54 (stock doesn't work properly)  and 1 from the S21(stock works).

0 Kudos
BarbaraWebster1
Esri Regular Contributor

Hi @AntonioBrcković, thanks for the additional information. I can see the same behavior if I change the locale of my device to Croatian. Can you confirm whether the devices that are not displaying correctly are set to Croatian and that the ones that are displaying correctly are set to English or another language?

This seems to be a localization issue, and I'm creating an internal issue so the Survey123 team can take a look.

The issue looks to be specific to integers, so a workaround for this survey could be to change the bind::type for the quantity_stock question from int to decimal. 

AntonioBrcković
New Contributor II

The devices that are not displaying correctly were indeed set to Croatian and setting them seems to have fixed the problem. The workaround works also.

Thank you very much for all your help.

0 Kudos
ChristopherCounsell
MVP Regular Contributor

Works fine.

Suggest updating Survey123 Connect and republishing the form, then updating Survey123 field app and redownloading the form.

Also would suggest adding some form logic so users can't enter negative values for stock out as it could be confusing. i.e. entering -5 to stock out, actually adds to the stock count. This could be the issue you're describing.

0 Kudos