Survey 123 form fails to publish

259
3
Jump to solution
10-16-2019 06:45 PM
YuliaMamonova
Occasional Contributor II

Hello,

I get an error (service definition creation failure) with the form attached.

I am sure it has something to do with my 2 geopoint questions that are set as "null" fields, and then lat and long calc is based on those questions.

I need starting and ending time and location of the survey. And I need to capture time/location exactly when the form is first opened and submitted and they should be read-only.

I found several approaches in geonet:

1) Repeats (I never use repeats in my surveys, cause I don't like related tables complications)

2) Multiple geopoints set as null

3) Pictures when they start the survey and then right before submitting.

So I tried 2nd approach, but apparently I did something wrong.

Can you please tell me what approach would be best for my workflow?

Thank you!

0 Kudos
1 Solution

Accepted Solutions
Jim-Moore
Esri Regular Contributor

Hi Yulia

Thanks for providing your XLSForm. It appears the publishing error is caused by a duplicate question name - there are two text questions named "truckdetails". If I rename one of these questions so that they're unique, the survey publishes as expected. Please let me know if this works for you.

Best,

Jim

View solution in original post

0 Kudos
3 Replies
Jim-Moore
Esri Regular Contributor

Hi Yulia

Thanks for providing your XLSForm. It appears the publishing error is caused by a duplicate question name - there are two text questions named "truckdetails". If I rename one of these questions so that they're unique, the survey publishes as expected. Please let me know if this works for you.

Best,

Jim

View solution in original post

0 Kudos
YuliaMamonova
Occasional Contributor II

Jim,

Thank you for your response.

This was exactly what prevented my form from publishing, but as I expected the location is not captured the way it is supposed to. What is the best way to capture ending location and make it static and read-only? So user cannot change ending location. Starting location will be captured automatically.

Thank you!

0 Kudos
Jim-Moore
Esri Regular Contributor

Hi Yulia

Good to hear we identified the cause of the error. Regarding your query about capturing start/end locations, I see this has been discussed in your separate post: https://community.esri.com/message/888133-re-capturing-location-several-times-in-survey123-form 

Thanks to James Tedrick‌ and Doug Browning‌ for their replies!

Best,

Jim