Survey 123 custom URL- Is there a character limit?

229
7
05-15-2019 01:01 PM
Highlighted
Occasional Contributor

Just curios, is there a character limitation when building the custom URL? My survey was working great until I tried to add another "field:" to pull one more value from my feature layer (highlighted part below) Now, when trying to submit new surveys from my Collector app my collected inspections are no longer being placed at the right location. Almost as if the part after "center=" gets ignored... This is what the url looks like when opened in a browser:

Reply
0 Kudos
7 Replies
Highlighted
Esri Regular Contributor

Hi Alina,

Yes, there is a limit of characters and also depends on what browser you use. See this link:

WWW FAQs: What is the maximum length of a URL? 

Reply
0 Kudos
Highlighted
Occasional Contributor II

Same problem...did you get it resolved? Esri support just suggested me to duplicate all the surveys 😕 Though I think the problem is in the number of fields being pre-populated from collector. I have 4 fields + cordinates

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Alina,

As Shwu-Jing mentions, the URL is under the maximum length.  Can you share your XLS file?

Reply
0 Kudos
Highlighted
Occasional Contributor

Hi James, 

See attached for the XLS file. Thank you for looking into it. 

I should mention this survey is strictly used in the iPad version of Survey 123. Using the 3.3 version. 

Alina 

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Alina,

I'm seeing the survey fill in properly given the link you have above.  Can you share the pop-up configuration (as HTML)? 

Reply
0 Kudos
Highlighted
Occasional Contributor

James,

Here is the HTML:

<a href="arcgis-survey123://?itemID=0fcb06e3dabf42b184c2caa3c2bc5b82&amp;field:FACILITYID={FACILITYID}&amp;field:TEMPDEPTHTOB={DEPTHBOB}&amp;field:TEMPPIPEOUTELEV={PIPEOUTELEV}&amp;field:TEMPINLETS={TOTALPIPE}&amp;field:TEMPSTRDIAM={STRDIAM}&amp; center={Lat},{Long}" target="_blank">Click for Inspection Survey</a>

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Alina,

I think I see a space after the field:TEMPSTRDIAM={STRDIAM}&amp; component - this could be blocking parameters after this section.

Reply
0 Kudos