Select to view content in your preferred language

Struggling to produce a link that can be clicked in Fieldmaps to take you to a new form and autofill some fields

558
3
Jump to solution
07-07-2023 06:11 AM
EdHixson
Occasional Contributor

Hi there

I have created a survey123 form to capture some information. This form then produces a feature layer which is accessible within fieldmaps. One of the fields is a link which can be pressed to open a new survey form and autofill some of the information from the point which had the link in.

This is the link I have produced but it doesnt seem to work 

https://survey123.arcgis.app/surveys/1c1222a033d94022ab2512863870f0eb?field:swabid={Swabid}&field:assetid={Assetid}&field:Project_Code={project_code} 

This link will open the survey123 app but wont open the specific survey with the auto filled values. I was wondering if anyone knew what I had missed from the link or whether having it as a read only field is the wrong way to integrate it into a feature.

 

EdHixson_0-1688735197057.png

 

Any help would be great

ATB

-Ed

 

0 Kudos
1 Solution

Accepted Solutions
DougBrowning
MVP Esteemed Contributor

The word surveys should not be in there  Also you are missing itemid part.

should be more like 

https://survey123.arcgis.app?itemID=1c1222a033d94022ab2512863870f0eb&field:swabid={Swabid}&field:ass...}  

try that. it is weird the http and app link are a bit different.

View solution in original post

0 Kudos
3 Replies
DougBrowning
MVP Esteemed Contributor

To have it clickable inside the form the only way I got it is to use a note field and have the link in the label column.  Try that.

Also I think your format is off.  See this post  https://community.esri.com/t5/arcgis-survey123-questions/cannot-open-survey123-link-in-field-app/m-p... 

0 Kudos
EdHixson
Occasional Contributor

Hi Doug

I have had a look at the link you sent and made a change regarding the & and ?. It doesnt seem to have helped though sadly.Anything else I am missing that I missed?

https://survey123.arcgis.app/surveys/1c1222a033d94022ab2512863870f0eb&field:swabid={Swabid}&field:assetid={Assetid}&field:Project_Code={project_code}  

Also sorry for some confusion I am not trying to pretty the link within the form but with Fieldmaps from a popup

ATB

-Ed

 

0 Kudos
DougBrowning
MVP Esteemed Contributor

The word surveys should not be in there  Also you are missing itemid part.

should be more like 

https://survey123.arcgis.app?itemID=1c1222a033d94022ab2512863870f0eb&field:swabid={Swabid}&field:ass...}  

try that. it is weird the http and app link are a bit different.

0 Kudos