Scale in mapsettings for feature report not working with geoshape

1253
9
12-20-2019 02:23 AM
leoficheu
New Contributor III

Hi,

I have a template for feature report in which are included two maps: one with the 50'000 scale giving an overview and one 5'000 scale.

This is working fine with geopoint question. It doesn't work with geoshape question, the scale is set to the feature extent.

Geopoint result:

Geoshape result:

${localisation |mapSettings:" 70a459d5e15f410d88eb66ae06d4cc6b":50000|size:200:220}

${localisation |mapSettings:" ce9ce9c68772456c8af1e7f33ee7bc70":5000|size:200:220}

Thanks for your help,

Léo

0 Kudos
9 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Léo,

To ensure that the polygons and lines are visible in the report, the feature report system ignores the scale parameter and bases the map on the feature's extent.  Could you provide details of how you use the maps in your reports so that we can better understand how to improve this?

0 Kudos
leoficheu
New Contributor III

Hi James, and thank you for your answer.

I was indeed thinking that it might be the intended behavior in order to keep the entire feature in the map. If it stays like this in the future, I think it could be useful to make it explicit in the documentation, as I spent some time (and credits looking forward for preview reports) trying to figure out the issue.

Here are some more details about what we are expecting, and why it is problematic in our case:

Context:

We have a hundred of different sites to control over an area of 3'200 km². Each site has its own report for our client.

We have two maps in the report, one on a small scale (1:50'000) giving information abour the location and one on a larger scale (1:5'000) showing the geometry. The issue in our case is more problematic with the small scale.

Expected behavior:

The small scale map in the report is supposed to give in one glance an indication of where is the site located in this area so that our client knows instantaneously which site the report is about.

Issue:

Without the larger scale, it is impossible to visually identify the site (as illustrated in the second picture), in other words, we lose the information about the location (which I think is rather paradoxical for a map-centered survey).

Suggestions:

- Let the user to set the scale, but somehow add a warning that the entire feature might not be comprised in the map if the scale is to large. The user takes then the responsability to set a fixed scale or let it by default.

- Calculate automatically the scale in the report as max("feature extent scale", user-defined scale)

- Add an option to map the centroid of the shape instead of the shape itself (not necessarily the best option, but it would be fine in our case)

Hope I made it clear, and I am truly willing to help if you have some more questions.

This is an important issue, which might prevent us from using geoshape and going back to geopoint. This would be a real shame as it was a long time hoped-for option and the result is great in my opinion apart from that.

Léo

JamesTedrick
Esri Esteemed Contributor

Thanks Léo,

This is very well-written and highlights the issue.  I should have asked you to do this first, but if you could double-post this into https://ideas.arcgis.com, that would allow us to better track user interest in this.

0 Kudos
leoficheu
New Contributor III

Thanks James, the idea is here.

As stated there, I do thing that "preventing" unwanted behavior by "restricting" customisation is not worth it in that case. The user should know on which scale he is working on, and if the shape goes out of the map, I don't think it should be a big deal to readjust it.

In the meantime, I am thinking of a workaround by combining geoshape (in a repeat) and geopoint for the main feature class. The geopoint would be read only and automatically calculated from the geoshape centroid cooordinates. Is there a way to pull the centroid coordinates of a geoshape?

0 Kudos
AndrewBowne
Occasional Contributor III

Great Suggestions!  I am facing the same issue as the OP.  I'd like to be able to show a location map along with a detail map.  This isn't possible with the current configuration.  I have voted up the idea and hope that it get's some attention.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Andrew,

Could I ask that you please check out the beta site (https://survey123beta.arcgis.com)? It has been updated to stay at a fixed scale when specified for polygon/line questions.

0 Kudos
AndrewBowne
Occasional Contributor III

Hi James,

Thanks for the reply.  I tried the beta site and it doesn't seem to be working.  Here is the parameter format I am using in my report template:

      ${location|mapSettings:” 183385a3954a4f90a31174ccea39dd26”:32000 | size:500:500}

Note that I am connecting to an on premise portal as opposed to ArcGIS Online.  I'm not sure if that makes a difference or not.

-Andrew

0 Kudos
JodyZhengLiu
Esri Contributor

Hi Andrew,

This is fixed in the latest release of Survey123 3.9, could you please have a try?

Thanks,
Jody Zheng Liu

0 Kudos
BenBlowers2
New Contributor III

Hi @JodyZhengLiu - I am still having this issue. Can you check on the status of this?

0 Kudos