Samsung Galaxy S4 GPS and Survey123

269
4
07-08-2020 06:19 PM
RalphBradt1
New Contributor II

I have two Samsung Galaxy S4s I've been using for data collectors with Survey123. I've used them successfully in the past, but now they will not connect to the onboard GPS. Both will show accurate GPS locations in Google maps, but both tell me "No position received" in Survey123. I've uninstalled my survey and Survey123 on both, then reinstalled. Same issue. Both say they're connected to the integrated provider, but I get no location. Both have permissions. Ideas?

0 Kudos
4 Replies
RalphBradt1
New Contributor II

Is it possible to install previous versions of Survey123? If possible, I might try that on one of the phones and see if an update caused the GPS disconnect. If yes, would it then automatically update back to the current version?

0 Kudos
RalphBradt
New Contributor

I have done factory resets on both units and successfully reconnected to GPS on one unit, but not the other. On both I tried deleting the .json file in AppStudio>Settings first without success.

0 Kudos
DougBrowning2
Occasional Contributor III

Do they have the same firmware? 

In the past I have had GPS just up and die on me also and had to send it into warranty (looks like Tab 4 is way out of warranty). 

Does a app like GPS test work?  Google can use wifi and such to guess.

Hope that helps

0 Kudos
RalphBradt1
New Contributor II

GPS Test worked on both, getting satellites equally well, as well as location in Google Maps and such using GPS only for location. Firmware was the same on both. At least I was able to get one to work through a factory reset. No great loss, I guess, since they were both older phones that have long since been replaced. At least I still have the one that I can lend out as needed. 

Thanks for the suggestions.

0 Kudos