Related View in Survey123 website is not working

67
4
Jump to solution
07-18-2019 04:15 PM
Highlighted
Occasional Contributor II

Hi,

This should be an easy and quick one. I am accepting to view the related records only when I select any record from the primary table, but can't get the result. Not sure where going wrong? Is this only applicable for those Survey created by a new version?

Any suggestions would be helpful.

Thanks,

Anu

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Regular Contributor

Hi Anu, thank you for the screenshots. Just to double-check, do you have the "Automatically select related records" option enabled?

There's also a filter to show only the selected records in the table (indicated by the arrow, above).

Thanks,

Jim

View solution in original post

4 Replies
Highlighted
Esri Regular Contributor

Hi Anu

The related table view should work with surveys published in older versions. Could you please provide some screenshots to illustrate what you're seeing?

Thanks,

Jim

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi Jim,

Thanks for the reply. I have attached a screenshot from Survey123 site. "A" is a primary table and "B" is a related table. 

Thanks,

Anu

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Anu, thank you for the screenshots. Just to double-check, do you have the "Automatically select related records" option enabled?

There's also a filter to show only the selected records in the table (indicated by the arrow, above).

Thanks,

Jim

View solution in original post

Highlighted
Occasional Contributor II

Hi Jim,

Thanks for the help. It's working now. Sorry I just missed this setting

Thansk,

Anu