"Open the survey" link button does not appear

243
3
10-20-2020 06:46 AM
EricA
by
New Contributor III

Hello,

We are using the browser version of Survey123 in conjunction with our Portal for ArcGIS 10.6.1. When a survey has a particular group selected for the setting "Who can view results of this survey?" (Collaborate > Share results), the survey now appears for other group members in the main My Surveys page of the website. 

However, only the survey owner and administrators of the Portal can see the "Open the survey" link button on the survey thumbnail. Is this expected behavior? Ideally we’d like for non-owners of the survey to be able to open the browser version of the survey by clicking on the link button from the My Surveys page instead of continually copy/pasting the URL.

Thank you,

Eric

0 Kudos
3 Replies
ColinLawrence
Esri Regular Contributor

Hi Eric, 

This sounds like expected behavior as you are sharing who can view the survey results, not the actual survey. You would need to share through the Collaboration > Share Survey tab to share the actual survey so they users can hit it from the My Surveys list. Correct me if i'm wrong Zachary Sutherby Sarah Bubka

Regards,

Colin

EricA
by
New Contributor III

Thanks for the response Colin! Unfortunately the survey was shared to the group through the Collaboration > Share Survey tab as well. As stated, they have no issues opening or accessing the survey via the survey URL, this is a question about why they don't have the link button to the survey on the thumbnail found on the My Surveys page. 

Thanks again!

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Eric,

The Survey123 website only supports viewing the results when a user logs into the Survey123 web site; to fill out the survey, they will need to use the link (or have the survey embedded in another application, such as ArcGIS Dashboard).

0 Kudos