Public survey issue with iOS and Survey123 v3.0

207
7
Jump to solution
07-16-2018 08:31 AM
New Contributor III

Hi,

I believe there was a recent bug fix in version 2.8 to fix a problem with public surveys in iOS Problem with public survey 

However, I have just downloaded version 3.0 (Bull release) on an iPad (iOS v. 11.3.1) and am still being asked to sign in to Survey123.  I have not been able to download my public survey onto the device without logging in.  Is there still a bug in  v 3.0 or is there a way round this?

Thank you,
Claire   

Tags (2)
Reply
0 Kudos
1 Solution

Accepted Solutions
Esri Regular Contributor

Hi Claire,

I have tested accessing your public survey on a iPad Air (A1474), running iOS 10.3.3 and was able to download successfully without being prompted for credentials.

Can you please try to download the latest version of Survey123 (3.0.134) and see if the issue persists?

Best,

Brandon

View solution in original post

Reply
0 Kudos
7 Replies
Esri Regular Contributor

Hi Claire,

Did you share the survey publicly via the 'Collaborate' options within the Survey123 website?

If so, are you then attempting to access the survey via the share survey link or QR Code?  Are you only encountering the issue on iOS devices, and if so, multiple?

If possible, please provide the share url to your public survey in a response to the private GeoNet message that I have sent you.

Thanks,

Brandon

Reply
0 Kudos
New Contributor III

Hi Brandon,

Yes, the survey is shared in the Collaborate tab, and seems to be working on Android fine.  We have tried two different iPads which both experience the issue, and have tried both the link and the QR code - both options still want a log-in.

I don't seem to have received the private Geonet message you sent - could you try sending it again, or offer an alternative way in which I can share the link with you?

Many thanks,

Claire 

Reply
0 Kudos
New Contributor III

Hi Brandon,

Has there been any progress with this?  We are still experiencing the problem.

Claire 

Reply
0 Kudos
Esri Regular Contributor

Hi Claire,

Can you please provide the specs of the iPads that the issue is being encountered on?  (iPad model, iOS version)

Thanks,

Brandon

Reply
0 Kudos
New Contributor III

Hi Brandon,

One of them is an iPad Air (A1475), running OS 11.3.1, the other is an iPad Mini - model ME277B/A, IOS version 11.4.1 (15G77)

Claire 

Reply
0 Kudos
Esri Regular Contributor

Hi Claire,

I have tested accessing your public survey on a iPad Air (A1474), running iOS 10.3.3 and was able to download successfully without being prompted for credentials.

Can you please try to download the latest version of Survey123 (3.0.134) and see if the issue persists?

Best,

Brandon

View solution in original post

Reply
0 Kudos
New Contributor III

Hi Brandon,

I have upgraded to 3.0.134 from 3.0.132 and this appears to have fixed the problem.  

Many thanks!

Claire