Problem with multiple repeat questions in one question group not appearing.

354
1
05-21-2018 07:21 AM
Highlighted
New Contributor III

I'm noticing that when I have two repeat type questions in a single group the repeat questions stop appearing. Does anyone have a workaround to this problem? Currently, I have two yes/no questions in a group called Hemispherical photo. Surveyors must take a photo at the location A and B. The first question in the group will ask the surveyor if they would like to take a photo at location A. If the surveyor checks yes a question repeated 3 times will ask for the surveyor to record the file name for each of the three photos taken at location A. The same goes for site B. However, I'm noticing that as soon as I put in another repeat question within the group, the repeat question will not appear for both location A and B. Ultimately the problem isn't about having multiple repeat questions within the form, it's more multiple questions within a question group that's causing the problem.

Please let me know if I can provide any further information. Thank you!

Reply
0 Kudos
1 Reply
Highlighted
New Contributor III

I just found out why things were not appearing, it was a silly mistake of not adding a counter. Once I added the counter to the repeated questions for location B (microplot) the questions appeared for both A and B. Initially my problem was I simply added a begin and end repeat type without adding anything in between. I find it strange that it caused my other question to not appear. Nonetheless, everything works again. I've added a screen shot of the working repeat question set up.

Reply
0 Kudos