Problem Downloading Templates and Connecting to Online Surveys in Survey123 Connect?

733
3
Jump to solution
03-03-2020 10:19 AM
AmberTobin
New Contributor III

I'm having a problem downloading most of the XLSForm design surveys in Connect. Any time I click on (for example) a template and click the "Create Survey" button I get "Download Error code: 503 503 Service Unavailable." I also can't download a survey I created on the web (with 10 yes/no questions). It just says "Downloading" 

I can only create a survey based on a Feature Service.

I'm working within the ArcGIS Online environment (No Server and no Portal). Can anyone else download a template? 

0 Kudos
1 Solution

Accepted Solutions
AmberTobin
New Contributor III

Turns out one of the websites that ESRI uses to store the templates was blocked by our IT.

Here is the document the ESRI rep shared with me.

http://downloads.esri.com/resources/enterprisegis/AGOL_Domain_Requirements.pdf

 

It was this link specifically: http://ago-item-storage.s3.us-east-1.amazonaws.com/ that I was blocked from.

View solution in original post

3 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Amber,

What version of Connect are you using? Is the survey you are downloading shared with you? 

What user role did you have with arcgis online? Are you able to create survey, delect survey or save survey from survey123 web designer?

0 Kudos
AmberTobin
New Contributor III

Hi Shwu-jing,

I just started using Survey123 on Monday (this week, 3/2/2020) and download the most recent version of Connect then (Survey123Connect_x64_3_7_62). I'm the admin for our AGOL account. My Agency has been using the AGOL for years now and I publish directly from ArcMap to AGOL weekly with no issues. 

I have a ticket in with ESRI support. Could be a firewall issue. I'm working with my IT department to see if the connection is being blocked on the back end. If that is the issue I will update my question. May be useful for other users if they ever come across this issue.

Thanks!

-Amber

0 Kudos
AmberTobin
New Contributor III

Turns out one of the websites that ESRI uses to store the templates was blocked by our IT.

Here is the document the ESRI rep shared with me.

http://downloads.esri.com/resources/enterprisegis/AGOL_Domain_Requirements.pdf

 

It was this link specifically: http://ago-item-storage.s3.us-east-1.amazonaws.com/ that I was blocked from.