Power Automate: Using Survey123 Custom Connector with ArcGIS Enterprise - How do I use "Create Report" action (Are there any Help Documents?)

1293
4
Jump to solution
03-28-2023 10:14 AM
rsun_TQB
Occasional Contributor III

Dear All,

We have been using the custom Survey123 connector on Microsoft Power Automate. It is working well, but I am still confused on how I can possibly using the S123 connector connecting to our Portal (ArcGIS Enterprise) with these exciting new S123 "Actions"?

rsun_TQB_0-1680023586500.png

Please teach me how to create "custom" actions for these actions to work with Portal.

Cheers,

Reno

0 Kudos
1 Solution

Accepted Solutions
ZacharySutherby
Esri Regular Contributor

Hello @rsun_TQB

You will likely need to recreate your ArcGIS Enterprise connector or update it and import the latest OpenAPI URL to get access to the create report connector. 

As for creating and using a custom connector in Power Automate that's more on the Power Automate licensing side of things. Please refer to the Microsoft documentation for more information on what license is needed to create and use a custom connector. 

Thank you,
Zach

View solution in original post

4 Replies
ZacharySutherby
Esri Regular Contributor

Hello @rsun_TQB

Please refer to this Esri Support KB article for the workflow to create an ArcGIS Survey123 connector for Power Automate for use with ArcGIS Enterprise. 

Thank you,
Zach
0 Kudos
rsun_TQB
Occasional Contributor III

Hi Zach,

My ArcGIS Survey123 Connector for Power Automate for use with ArcGIS Enterprise only have one action available.

rsun_TQB_0-1680057778060.png

 

However, AGOL Survey123 has the "Create report" action that I would like to try. Are there ways for Enterprise users to have "Create report" action available as well?

rsun_TQB_1-1680057836245.png

Are Survey 123 triggers and actions for Enterprise users always going to need "PREMIUM" Power Automate license?

Thanks a lot,

Reno

0 Kudos
ZacharySutherby
Esri Regular Contributor

Hello @rsun_TQB

You will likely need to recreate your ArcGIS Enterprise connector or update it and import the latest OpenAPI URL to get access to the create report connector. 

As for creating and using a custom connector in Power Automate that's more on the Power Automate licensing side of things. Please refer to the Microsoft documentation for more information on what license is needed to create and use a custom connector. 

Thank you,
Zach
rsun_TQB
Occasional Contributor III

Thanks! Got it now 🙂

Step 1: Update from OpenAPI URL

rsun_TQB_1-1680117667638.png

 

Step2: Import an OpenAPI from URL

https://survey123.arcgis.com/api/template/swagger?portalUrl=<ENTERPRISE_URL>

rsun_TQB_2-1680117730391.png

Step3: Re-entered ClientID, Client Sceret, and Refresh URL

Step4: Click Update connector

rsun_TQB_4-1680117865483.png

 

Step5: Check if you are now getting new Triggers and Actions of your Survey123 Connector for ArcGIS Enterprise.

rsun_TQB_0-1680117621366.png

Step6: Make sure you "Switch account" of your Survey123 connections (I wish we don't need to this, but I think we have to.)

rsun_TQB_0-1680118291064.png

 

Cheers,

Reno

0 Kudos