Select to view content in your preferred language

Power Automate Create Report Token Expiration?

1199
4
Jump to solution
06-21-2023 04:29 AM
RobertAnderson3
MVP Regular Contributor

I've absolutely loved using the Create Report action that has been added to Power Automate, however I have run into this issue twice now where my flows start failing and I see the error message:

RobertAnderson3_0-1687346854198.png

Has anyone else been experiencing this issue? I know the ArcGIS Connector itself had a 14 day timeout on the token for a while, but never saw this with Survey123. As soon as I go to my connections and sign back into the Survey123 connection my flow works fine again. 

Is this a known limitation or am I doing something wrong?

1 Solution

Accepted Solutions
RobertAnderson3
MVP Regular Contributor

Okay so just as an update I've finally seen an official note on this in a post from @IsmaelChivite in his post of a Tricks of the Trade session here: https://community.esri.com/t5/arcgis-survey123-videos/survey123-tricks-of-the-trade-live-automate/m-...

  • Why my flow fails stops working after 2 weeks? Because the Survey123 connection expires after two weeks. Refresh the connection in Power Automate to keep it going. The team is working to address this problem.

Went digging back through on his Create Report Preview Blog Post and found the link to the new thread. I wish this was documented officially anywhere as a limitation by Esri or on the Microsoft page (even contacting support they were unsure).

I hope this timeout gets bumped up quickly.

View solution in original post

4 Replies
rsun_TQB
Occasional Contributor III

Hi @RobertAnderson3 ,

Same for my flow, and thank you for your post...so I noticed that our flow is not working with "Create Report" action. 

rsun_TQB_0-1687367779306.png

I re-log on of our S123 connection, and the flow is working again...

I found it's annoying to need to do this all the time lol... I scheduled to refresh S123 connection every 2 weeks from now on to avoid this issue.

Thanks,

Reno

RobertAnderson3
MVP Regular Contributor

It's definitely annoying to have to deal with, I'd be curious to see, how did you schedule the S123 refresh?

RobertAnderson3
MVP Regular Contributor

Okay so just as an update I've finally seen an official note on this in a post from @IsmaelChivite in his post of a Tricks of the Trade session here: https://community.esri.com/t5/arcgis-survey123-videos/survey123-tricks-of-the-trade-live-automate/m-...

  • Why my flow fails stops working after 2 weeks? Because the Survey123 connection expires after two weeks. Refresh the connection in Power Automate to keep it going. The team is working to address this problem.

Went digging back through on his Create Report Preview Blog Post and found the link to the new thread. I wish this was documented officially anywhere as a limitation by Esri or on the Microsoft page (even contacting support they were unsure).

I hope this timeout gets bumped up quickly.

SherryChan
New Contributor II

Hello!

Has the Esri team found a solution to prevent Survey 123 from expiring after 2 weeks?    If not, what can I do meanwhile?    Please advise.  Thank you

Sherry