Post-submission editing of a public survey by back-office staff

590
3
05-10-2021 01:42 AM
Jon_Tait
New Contributor II

I have a simple survey which is shared with everyone as we want the public to be able to report issues to us using a simple web browser. The survey was created in the web designer as I'm new to this software and the Connect system is beyond me.

I've built a dashboard and we'd like system users to be able to edit a survey once it has been submitted to show that the survey has been actioned. In the survey there is a small 'For office use only' section at the end and this is the bit I'd like back-office staff to fill out to action that survey.

 

I've created a list in the dashboard with a link to the survey using the following:

https://survey123.arcgis.com/share/<<surveyID>>?mode=edit&globalId={globalid}

When I click that link the survey opens up alright, I can edit the survey and re-submit it and the data is reflected in the dashboad, but when anyone else in my teams tries the same it doesn't work (even a group of named licensed users whom I've shared the survey results with in the collaborate tab. The survey itself is shared to 'Everyone'.

Am I doing something wrong? Or is this not possible?

Many thanks
Jon

 

 

Environmental Control Officer
East Riding of Yorkshire Council, UK
3 Replies
IsmaelChivite
Esri Notable Contributor

I am guessing that the permissions in the survey layer are set to avoid other users from editing the data.  Since you are the owner of the survey, you can edit, but others may not have edit permissions.

In the Collaborate tab, make sure you have the 'Add and an update records' option on. Also make sure you hit Save.

IsmaelChivite_0-1620662295834.png

If the above is all set correctly, and it still does not work, please provide some details about what you mean by 'it does not work'.

0 Kudos
Jon_Tait
New Contributor II

Good morning Ismael


Thank you for your prompt reply. I've followed the steps in your reply and I can now link the List in the dashboard to the embedded survey123 form and when I click on a list item the right survey shows in the form. But if I'm logged out of my ArcGIS Online account (to replicate another back office user) when I try and edit the form and press submit I get the following error message:

Failed to submit. - No permission to edit the specified feature.

Our set up here is perhaps the problem. We have a limited number of users with full AGOL accounts and then the rest of the staff have access to our own Enterprise portal which isn't public. Therefore to create a public survey I have to create it it AGOL, make it available publicly, then import the results feature layer into the portal and embed my credentials. i then use that layer in the portal to build the dashboards etc that staff will use in the back office to see the survey data, and hopefully be able to edit it.

I hope that makes sense
Jon

Environmental Control Officer
East Riding of Yorkshire Council, UK
Environmental Control Officer
East Riding of Yorkshire Council, UK
0 Kudos
Jon_Tait
New Contributor II

Hi Ismael, were you able to find a solution? Many thanks, Jon

Environmental Control Officer
East Riding of Yorkshire Council, UK
0 Kudos