Position(..) malfunction in repeats in survey 123

294
3
01-01-2022 08:13 PM
JuanSthebanSanchezAragon
New Contributor II

Hi, I´m using the position(..) tool to get the position for each repeat in my survey, but there´s an issue when a repeat in between is deleted.

As an example lets say I have 4 repeats, the counting would be 1,2,3,4, if I delete the third one the order should update to 1,2,3, but instead it shows 1,2,4. The idea for it is to be automatic so it is a hidden field. thanks so much for reading, and really hope there something to do.Repeat calculation.JPG

Repeat position.JPG

Have a wonderful day.

3 Replies
FrankOuyang
Esri Contributor

I tried it in my Survey123 Connect but didn't encounter this problem after deleting entries in the repeat. Can you post more rows in your table so we can see what's in the whole repeat group? And are you using the latest version of the software? 

0 Kudos
JuanSthebanSanchezAragon
New Contributor II

Hi, thanks so much for replying, this is the excel I´m currently working with to do the position task.

0 Kudos
DerrickWestoby
Occasional Contributor III

try this modified XLS instead (added row 9, changed row 8 calculate column). 

I don't know if this is still true on the most recent version of S123 connect, but I think that using position(..) in an integer field won't (or wouldn't) update if a change was made.   At least in my currently published surveys, they -will- auto-update if I use a calculate type to pull the position, then update my hidden integer field from the calculate.    (Which you can still prevent by using once(position(..))  )

 

 

0 Kudos