Photos in survey are not showing!

66
6
08-08-2019 12:28 PM
Highlighted
New Contributor

Good afternoon.

Have an issue with a survey that doesn't show the pictures, the thing that 1 week ago it was showing it until I got a called that the pictures wasn't showing in the uploaded surveys. I don't have as many records because this survey is in a "Pilot" phase but still need the pictures to be there.

From those 34 records on "Ottawa patrols", every one of them had pictures but now are not showing (see screenshot above). Only in one of the "repeat" questions that is on the last tab is showing the pictures (see screenshot below).

Just created a new survey and the field guys are using that one, wonder if there is a way to "restore" the photos from the "Ottawa Patrols" survey. 

Please let me know if it's possible.

Thanks.

Reply
0 Kudos
6 Replies
Highlighted
Esri Esteemed Contributor

Hi Angelo,

Could you check the feature service via the Item Details page's Data tab and see if the attachments are present?  Was the image question capturing the photos renamed during the form creation process?

Reply
0 Kudos
Highlighted
New Contributor

Hi James.

There are no attachments in the feature service.

The weird thing is that only is showing on the repeat repaired.:

The image question wasn't renamed. It is a "repeat question" that shows like this:

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Angelo,

This looks correct based on the form design - because the photo is in a repeat section, they will be in attached to a record related to the primary record.

Reply
0 Kudos
Highlighted
New Contributor

so, can I retrieve the photos or not?

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Angelo,

Re-reading the initial problem, it appears that the photos for many of your records are not present.  Just to check, was this form published, edited, and then re-published?  If you had added a repeat section, for example, that would have caused the feature service to be re-created.

Reply
0 Kudos
Highlighted
New Contributor

Yes, it was published, edited with minor changes (not adding repeats) and then re-published. 

Reply
0 Kudos