Phone Number Field Misbehaving

657
5
12-23-2019 09:48 AM
bobwright
Occasional Contributor

We have been using Survey123 on Android tablets to capture harvest info including hunter phone number (with the body::esri:inputMask constraint of (999) 999-9999) with no problems. On December 17th I reduced the list of check stations in the form, republished it, updated Survey123 (3.7.56?) on the tablets and downloaded the updated form. During subsequent field data collection it was brought to my attention that attempts to enter a phone number resulted in skipping, overwriting and other misbehavior that rendered the field unusable. Updating Survey123 to the latest version (3.7.57) did not resolve the issue. Further testing indicated that any form with this phone number constraint works correctly if it was downloaded prior to the Survey123 upgrades I did on December 17th and December 20th. Using the most recent version of Connect (3.7.62) does not make any difference either. Attached is the spreadsheet for a form that works correctly if downloaded before the December 17th app upgrade and not afterwards. Thanks.

Tags (1)
0 Kudos
5 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Bob,

What brand and version of android tablet are you having issue with? I was not able to repro the issue using android phone with v.3.7.57 though, sending survey was ok and successfully. Could you provide more details of the tablets you are using? Did the issue also occur with other devices such as android phone or iOS phone?

0 Kudos
AndrewOldham1
New Contributor

We too are having this issue. Ever since the new release (3.7.57) android devices (For example, one of them is a Samsung Galaxy S7 - Android 8) are not behaving correctly (like the above user stated) when entering a phone number. If you enter 3 numbers, it doesn't auto step past the dash (like it used to) and instead only jumps past the dash when you enter a number then jumps back in front of the number you just entered. When you enter one more digit it just overwrites the previous digit. I know that is hard to follow but if you enter 1234567890 it normally would format along and you would get 123-456-7890 now you get 123-567-90. It is very odd...

The phone number field is text - length 12 with an inputMask of 999-999-9999 and until this release has functioned without any problems. on all devices.

I'm not experiencing this issue with iOS or the Windows desktop app.

0 Kudos
AndrewOldham1
New Contributor

Update...

As a work around of sorts, I changed the Appearance of that particular question to Number and with that different setting of data entry (more user friendly anyway) the buggy skipping doesn't happen and the user can enter the phone number as usual.

0 Kudos
bobwright
Occasional Contributor

Thanks for sharing the work-around Andrew. I’ll save it for future reference. Unfortunately I don’t think it works for us because it requires changing the field type, which would require deleting the field and adding it to the end of the feature service or publishing a new feature service, both of which would significantly disrupt a very important workflow. Perhaps I’m missing something?

ESRI support – Anything new from you? Thanks.

Bob

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Bob,

My testing device is Pixel3, an android phone with version 10 and I'm not able to repro the issue as you described. It might be device or android version specific. Have you contact Esri Support to open a ticket to troubleshoot this? If not, I will encourage you to do so and Esri tech support will assist you further on this issue.

0 Kudos