Passing values via submission URL from Collector vs. Webmap

384
5
07-18-2018 01:08 PM
Highlighted
New Contributor III

Hello all,

The background for this post is that I have a webmap containing a polygon layer whose pop-up has a submission URL hyperlinked to Survey123.  It appears that the issue is that any value from a domain which contains a space in the domain Description does not pass/match-up with a select multiple box label value in Survey123, when sent from Collector.  If I click the pop-up submission URL from within a web map in an AGOL map viewer, it launches Survey123 with the values populated. 

I've tested the Collector to Survey123 workflow on an iPad mini 4 and on an Android Galaxy S7 where the values were not passed.  

I've tested the AGOL map viewer to Survey123 on Windows 10 Chrome, iPad mini 4 Safari, and the Galaxy S7 Chrome.  

Has anyone seen this?  I've searched submission urls and not found any related issues.  I'm thinking that replacing the spaces with underscores in the Domain Code Description would be a workaround and will test that after the users do some UAT.  

Thanks in advance for any help!

Jim

Reply
0 Kudos
5 Replies
Highlighted
Esri Regular Contributor

Hi Jim 

Having spaces in choices name values is not supported for select multiple questions.

This is dictated by the XLSForm specification.

So underscores in the name should work.

Thanks

John

Highlighted
New Contributor III

Hey John,

Thanks for responding.  For clarity, I have underscores in the name field and spaces only in the label field on the choices tab.  Below is the portion of the submission url that is in question.  

&field:business_name={Business_Name}&field:block_name={Block_Name}&field:temperature={Temperature}&field:cloud_cover={CloudCover}&field:wind={Wind}&field:precipitation={Precipitation}

If I understand correctly, the values being matched up here are the feature class domain Description and the Survey's choice Label, correct?  

Again, all works fine when launching from a browser instead of Collector.  

Thanks again!

Jim

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Jim

Yes, the domain description and the survey's choice Labels are being matched.

Sorry, I misunderstood you. As you say, spaces in the labels of choice lists are supported. This looks to be a bug with Collector as it is not handling the space in the URL correctly. Could you raise this as a bug with support, so we can attach a customer to it?

Thanks

John

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Can you test if a %20 works in place of the space? It sounds like we may want to ask for a urlencode function in arcade.

James

Reply
0 Kudos
Highlighted
New Contributor

I'm getting the same error when passing a domain coded value over through the submission URL to Survey123. Works fine via the AGOL web map but when through collector, it comes into Survey123 with a line through it.

Reply
0 Kudos