Open an existing record from the S123 Feature Layer in the Survey123 Field App

365
1
Jump to solution
05-14-2021 05:33 AM
AndrewVitale
New Contributor III

Hello,

I'm trying to integrate an application with Survey123 using the documentation found here:
https://doc.arcgis.com/en/survey123/reference/integratewithotherapps.htm

In our application, users will be presented a map of features from a system of record (SOR). From there, they may decide they want to update that record with new information gathered from the field. For the field work, we're using ArcGIS Survey123, which has the benefit of isolating the field data in a Feature Service, allowing the field data to be reviewed before loading it into the SOR.

The features from the system of record are polygons, many of which have been created by buffering points. Thus, they have too many vertices to be passed to the ArcGIS Survey123 field app in the URL using the `field:fieldName=This%20value` syntax.

To get around this, we're using the /applyEdits endpoint of the S123 feature service to POST a new record with the data from the SOR from our JavaScript application. Once the new record  is created, we would like to use the globalid (or ObjectId) to open the field application to the newly created feature.

This workflow seems to work well with the Survey123 Web App. Using the `?mode=edit&globalId=uuid` style query, the app opens up to the new feature. However, when I try to carry this same logic over to the Field App (which is what our requirements call for), the app keeps opening to an empty form.

I've created a super-simple survey and shared it publicly to exemplify the issue in this CodePen:

https://codepen.io/vitale232-the-vuer/project/editor/DNeRYO?open_file=index.html 

FWIW, the S123 form we're trying to get to production has many repeats. However, we're not trying to carry over any of the repeat fields from the SOR.

Does anyone know what's going wrong here? Why can't I open a feature that would be in the inbox without using the inbox?

The documentation seems to imply that this is a viable solution.

Thanks for reading!

0 Kudos
1 Solution

Accepted Solutions
ZacharySutherby
Esri Regular Contributor

Hello @AndrewVitale

We have a defect logged where unfortunately at the moment the Survey123 Field App has an issue trying to open individual forms. Please feel free to reach out to Esri Technical Support and they will be able to attach you to the defect so you can track the status of the issue.  

Thank you,
Zach

View solution in original post

1 Reply
ZacharySutherby
Esri Regular Contributor

Hello @AndrewVitale

We have a defect logged where unfortunately at the moment the Survey123 Field App has an issue trying to open individual forms. Please feel free to reach out to Esri Technical Support and they will be able to attach you to the defect so you can track the status of the issue.  

Thank you,
Zach