Loss of data on Survey123 form when switching between apps

405
3
07-16-2020 12:30 AM
RafaeldePedro
Occasional Contributor

Hi, 

A colleague of mine informed me of an issue he's had a few times (not always) when filling in Survey123 forms. He would switch app in the tablet, and open Google Drive, in order to look up a number that he will need to enter in one of the Survey123 form fields, but when he switches back, the data has been lost and a blank form is displayed. Apparently, in fact, he received a message saying something like 'survey recovered' and 'what do wish to do', and he would choose 'continue survey', but instead it's a new blank form. However, when I tried to do it on my own device, everything works fine. I don't even have to choose anything like 'recover form' or similar. Everything I type just stays there, which is what I would expect.

I was told this over the phone so I might have not worded the messages displayed on his screen correctly, but this is the essence of the problem. Does this sound familiar to anyone here?

Thanks

0 Kudos
3 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Rafael,

Could you provide more information on the mobile device where the problem occurred? What model is the mobile device and what OS version does the device run on? And what version of field app is being used on that device. If the survey is not sent but closed unexpectly, the data should be recovered when openning the app again. More details on the issue would help us to identify what the issue might be.

0 Kudos
RafaeldePedro
Occasional Contributor

Hi Shwu-jing,

Thanks for your reply. The device was a Samsung Tablet (Galaxy Tab A 2018 SM-T595). He couldn't confirm, but given the model, I'd assume the OS is Android 81. The version of Survey123 is 3.9.149.

I'm afraid all the details I got were already described. He would just switch to Google Drive to look up a number while in the process of filling in a S123 form. Then when going back to S123 (in the same normal manner that we all switch between apps on our phones), all the info entered for that form so far had disappeared. and a new blank form was displayed instead, after reacting to the pop up message about 'Recovering survey' and choosing to 'continue survey'. For the time being, I have suggested to save drafts when leaving the S123 app, even if momentarily, and re-open the draft form to continue. I haven't had any reports from anyone else, but I thought this occurrence is quite odd, and would like to understand what could cause it. 

Thanks again.

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Rafael,

Thanks for the additional information. I did a quick test with 3.9.149 on my Pixel3 android 10 but I wasn't able to reproduce the behavior you described. Could this table be upgraded to the latest android version? Is the same survey form working with other similar android tablets? How about iPad? If the issue only occurred with this particular Samsung Tablet device, I'd suggest you contact Esri Support to log a ticket so that we can get a reproducible case in house, in order to investigate this further.

In a normal case, when you fill in the survey and leave survey 123 app(in background) to switch to other apps, you should be able to get back to survey123 and all data should stay. Unless you close the survey without sending or saving, the survey will ask you to "Delete" or "Continue", which will resume the previous data. 

We would definitely need more details to investigate this and a ticket with Esri Support would help us to get a repro case in house.

Thanks,