Link to Field Maps from S123

407
4
04-19-2021 09:37 AM
danbecker
Regular Contributor

We are able to construct a URL in S123 form to open Collector, initiate a point and pass attributes from S123, works great. But we're unable to open the Field Maps app from S123.

Here's the doc that lists which apps can be launched from S123:

https://doc.arcgis.com/en/survey123/reference/integratewithotherapps.htm#ESRI_SECTION1_BB1D69DBE8334...

Looks like Field Maps is missing, and I confirmed that "arcgis-fieldmaps" doesn't work to launch the app.

Are we doing something wrong, or hasn't Field Maps been integrated with S123 yet?

The opposite direction works, clicking a link on Field Maps successfully opens the S123 form, but you can't get back to Field Maps from S123.

0 Kudos
4 Replies
ZacharySutherby
Esri Regular Contributor

Hello @danbecker

It looks like the app link for Field Maps is https://fieldmaps.arcgis.app. Please use this link for reference regarding the Field Maps documentation for app links: https://doc.arcgis.com/en/field-maps/ios/help/deploy-your-map.htm

I'll create an issue in our documentation repo now to add the Field Maps link to our documentation. 

Thank you, 

Zach

DougBrowning
MVP Frequent Contributor

Can anyone see anything wrong with this URL?  It opens Field Maps and my map but it will not create a new feature.  I do a lot of linking from Field Maps to 123 but cannot seem to go the other way.

https://fieldmaps.arcgis.app?referenceContext=addFeature&itemID=60898699d9194370985ba5d1b88ac966&featureSourceURL=https://services1.arcgis.com/Hp6G80Pky0om7QvQ/ArcGIS/rest/services/PFCRCTest4/FeatureServer/0 

I also noticed that this link does not work at all if I am already in field maps.  I would like to have a URL from one feature to another feature inside the same map so I can pass IDs.  Going opposite direction of the relationship class so it hides the Add button in the child.

thanks

0 Kudos
DougBrowning
MVP Frequent Contributor

Well I got some of it.  The  /ArcGIS/services part needs to be lower case /arcgis/services.

I got this because the rest is diff if you go to a layer vs the top level of the service

Top level

DougBrowning_0-1621977564776.png

 

But the layer is goes caps

DougBrowning_1-1621977621489.png

 

Now that's crazy.  Seems like a bug to me.

So now I get farther but it still asks me which layer and will not pass in any attributes.

Any ideas why it makes me tap the layer name?  It is not passing any attributes because of this.

Edit I got it to pass attributes but I still need to tap the layer name in-between.  Not sure why.  Collector does this also though.

 

thanks

0 Kudos
ZacharySutherby
Esri Regular Contributor

Hello @DougBrowning

I would suggest reaching out to the folks on the ArcGIS Field Maps community to dig deeper into the issue, or create a case with Esri Technical Support and they will be able to take a look into the issue. 

Thank you, 

Zach

0 Kudos