Launching Survey123 Field APP From Web Map Popup

362
5
04-10-2019 02:54 PM
Highlighted
Occasional Contributor

I am having difficulty launching the Survey123 App from ArcGIS Online Web Map popup.  I am following the driections provided in https://doc.arcgis.com/en/survey123/reference/integratewithotherapps.htm . 

I am using Google Chrome browser to access the map.  The Url the Popup is set as arcgis-survey123://?itemID={formid}   (it opens up in the web app https://survey123.arcgis.com/share/{formId}  without any problems) but nothing happens instead Chrome just opens a tab with that URL and gets stuck. Does this mean that Chrome does not know that I have installed Survey123 Field App already or am I missing something else? 

The final thrust of opening the field app is to include a key field name and variable so as to open a record for review in Survey123 field app.  Is that a possibility? 

5 Replies
Highlighted
Esri Contributor

Hi Maaza,


What happens if you type arcgis-survey123:// into chrome (without your itemID)? This should prompt you to launch the field app.


It sounds like the registry key that launches the field app (from the arcgis-survey123:// URL) is either corrupted of missing. Open Regedit from the command line and have a look to see if this folder exists: HKEY_CURRENT_USER\Software\Classes\arcgis-survey123. It should have an entry that specifies the path for the Survey123forArcGIS.exe:


If the entry doesn't exist, you may need to delete the arcgis-survey123 folder and re-install the field app. The correct registry entries will be recreated when you install.


Depending on your work environment, registry access may be disabled by a group policy. This means that the registry entries can't be created when you install. You won't get any warnings of this during the installation so you'll have to refresh the registry view and check again yourself to confirm.

Hope this helps,

Brett

Highlighted
Occasional Contributor

That could be the issue.  I don't have admin privileges on the machine I am working and I was pleasantly surprised that Survey123 Connect and field app don't require admin privilege to install.  So it is that Chrome has no way of finding anything except a google search is done using the arcgis-survey123://  command. 

Reply
0 Kudos
Highlighted
Frequent Contributor II

I had this problem in windows also.  You can install not as admin, but if you do, it seems that the program associations never get set - so windows has no idea.  That said I have not had much luck ever getting windows to work.

Highlighted
Occasional Contributor

Thank you Doug for the input.  It works for us if one is logged in as admin user, but will not work at all as an individual user with Admin Privileges.  I am not sure what the underlying difference is but I thought maybe domain controllers are also an issue as the logins are based on them.  But allowing a web-browser to open an executabel seems to me a very sensitive procedure and allowing such a process even on a mobile device let alone a desktop is not very wise.

But I is there no other way to go about this problem?  Any workaround?  

Reply
0 Kudos
Highlighted
Frequent Contributor II

I think there was a post somewhere about hacking the registry to get the HKEY Local User set properly.  I can't find it now.  I never tried it though.  One of the reasons we are doing 123 is to dump windows tablets and go to Android/iOS.  I did have a coworker trying and never got it just right i think.

Reply
0 Kudos