Issues with Survey123 on Win 10 and Andriod

426
8
05-27-2018 08:27 PM
Highlighted
Occasional Contributor II

Hi All,

one of users is trying to use Survey123 on a Surface Pro (Windows 10) and Samsung Note 8 (Andriod). When attempting to open an existing Form (downloaded) the app stops responding and the only way forward is to crash out of the app.

The user let it sit for about 15mins and it eventually opened but was significantly slow when using the device.

We have installed the Application on Windows 10 locally (before the forms would save in a roaming profile) both App and forms and we still get the same result.

When testing Survey123 Connect for ArcGIS on a Windows 10 Desktop/Laptop it failed to load the form.

We have tested on iOS (iPad Pro 9.5inch) and it worked straight away with no issues in loading and using the form.

I have attached the form for anyone to test.

Thanks

Andrew

Reply
0 Kudos
8 Replies
Highlighted
Esri Frequent Contributor

Hi Andrew,

Can you confirm what version of the Survey123 app you are using on these devices that are crashing?

Phil.

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi Philip Wilson

Please see the attach Screen Captures for each Device:

Windows 10 - Surface Pro 4                                                              Andriod - Samsung Note 8

Thanks

Andrew

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Thanks Andrew,

When referring to "When attempting to open an existing Form (downloaded) the app stops responding" do you mean when opening the survey to do a new collect, or opening an existing survey from the Inbox to edit?

I have downloaded you xlsx form and published as a new survey and feature service to Online with Connect (v2.8), and also tested downloading and submitting surveys in the App on Windows 10 and Samsung S8 with Android 8.0.

I was unable to replicate any crashes using your survey.

Are you able to replicate the crash every time? If so, on Windows 10, do you have AppStudio (or can you install it) so we can use the Console to gather the logs at the time of crash?

Phil.

Highlighted
Occasional Contributor II

Hi Philip Wilson‌,

Open the survey to collect new data. I remember have similar issue with this form a while back when an update occurred to Survey123. So Survey123 Connect for ArcGIS took 560s (9mins) to open the form.

I need to aviod creating a new Feature Service/Survey as this is currenlty being used by users.

I will download AppStudio and check in the consolde for error.

Hopefully i will get to this today

Thanks

Andrew

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi Andrew,

Just following up to see if you had any luck with AppStudio Console to get the logs?

Phil.

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi Philip Wilson‌,

Sorry for the delay have been on leave. I havent had a chance to follow up with our User to get his device to install AppStudio on his pro. Hoping either today (Thursday) or Friday.

Thanks

Andrew

Highlighted
Occasional Contributor III

We're having similar issues with the survey123  on windows 10 platform. I have app studio downloaded on my PC how do I generate the logs?

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi Jordan,

You can open the AppStudio Console (a button at the top of the screen) which is available in AppStudio, and then open Survey123 and go to the Settings and enable logging in the Diagnostics. This will write the logs from Survey123 into the Console.

Phil.

Reply
0 Kudos