Issues with new search appearance, domains, and ArcPro editing

316
3
Jump to solution
11-16-2021 11:56 AM
DougBrowning
MVP Notable Contributor

Running into an issue with the new search appearance and domains.

For some reason when using the search appearance 123 is creating a domain with the word label in it.  I think it is creating this from the choices sheet.

This is breaking editing in the web map and ArcPro.

WebMap you are totally stuck

DougBrowning_0-1637091861263.png

In ArcPro it goes red and creates a hard stop both in the attribute table and in the attributes window.

DougBrowning_1-1637091943418.png

This causes us to not be able to edit our data - even other fields!  Totally stuck.  Only workaround is to use field calc.  This is fine for advanced users  but basic users are totally lost on the red errors and it is causing us lots if support calls.  We can turn it off but the QA people hate that.

Can you take the simple name/label domain out of there please?  Seems like 123 should check to see if you use search then not create this domain.

Note this is similar to an issue I posted here where not updating the domains is causing a similar issue.  This means 123 and ArcPro become incompatible.  James had posted he did not see this but I have screen shots so it for sure does - he may have used the setting below.  https://community.esri.com/t5/arcgis-survey123-questions/arcpro-is-not-allowing-editing-of-123-forms...

For now we have to turn it off totally which is not ideal.

DougBrowning_2-1637092306372.png

 

Thanks for any help

0 Kudos
1 Solution

Accepted Solutions
Philip-Wilson
Esri Notable Contributor

Hi @DougBrowning,

Just wanted to let you know with the upcoming 3.16 October Release of Survey123 we have made improvements to Connect publishing with regards to domains and also not creating a domain when using search() appearance. You can check out the latest announcement, documentation and test out the latest 3.16 beta builds via the Early Adopter Community to get early access to these builds and the new publishing workflows.

Regards,

Phil.

View solution in original post

3 Replies
DougBrowning
MVP Notable Contributor

I was able to go into the service and remove the domain.  It had just the words name and label in there.

Can a check be added to not create domains for search appearance types?   If the domain is just name and label then it should not be created.

thanks!

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @DougBrowning,

Just wanted to let you know with the upcoming 3.16 October Release of Survey123 we have made improvements to Connect publishing with regards to domains and also not creating a domain when using search() appearance. You can check out the latest announcement, documentation and test out the latest 3.16 beta builds via the Early Adopter Community to get early access to these builds and the new publishing workflows.

Regards,

Phil.

IsmaelChivite
Esri Notable Contributor

Thanks for reporting this @DougBrowning  I have added an internal note to document this problem.