IndexOf undefined error on collaborate

1176
5
04-06-2020 02:01 PM
ChuckBargeron
New Contributor

When I try and save a Survey123 form's submitter settings in the online "Collaborate" tab, I keep getting a "Failed to save- Cannot read property 'indexOf' of undefined error". 

The form, published feature service and hosted feature service are all set to Public. 

We recently upgraded Survey Connect to 3.7.62 - would that have broken the form? 

When I try and create a new survey using the same existing feature service, and publish it I am getting the same error.  

Anything I should be looking at in particular? 

Tags (1)
0 Kudos
5 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Chuck,

Was this feature service created by Survey123 or another application?  You may want to open a support case to further troubleshoot what might be at issue.

0 Kudos
ChuckBargeron
New Contributor

Hello James

The feature service was created in ArcGIS 10.5 and published on our ArcGIS server. We registered it with AGOL and created a proxy. The issue happens when I create a new survey or an existing survey. 

I'll look into a support ticket if no one has any suggestions.  

Thanks

0 Kudos
StefanieWenker
Occasional Contributor

Hi Chuck,

I am having the same issue, did you end up creating a support ticket?

0 Kudos
DavidNovak
Esri Contributor

Survey123 for ArcGIS
The same issue on my End. Where is the problem? Can't save Collaborate settings on any my form.
Form was created on AGOL from App icon. Feature layers was created with form.

0 Kudos
StefanieWenker
Occasional Contributor

Hi David, 

I did end up submitting a support ticket and got the following response: 

  1. BUG-000130147 : Unable to change settings in Submitter section under Collaboration on Survey123 website when the survey is created using referenced feature service on Portal for ArcGIS.

I was able to control permissions using my feature service settings and by changing the sharing settings in my AGOL content instead of doing it in the survey123 window.