Inconsistencies between web form and mobile app

140
5
Jump to solution
09-11-2019 11:26 AM
Highlighted
New Contributor III

I am noticing inconsistencies in behaviors between the IOS survey123 app and the web form.

Here are 2 behaviors that I prefer the web form behavior.

1) When using pages, if a page (group) is not relevant the page will not be displayed or counted when using the web form, but will display a blank page when using the IOS app.

2) When submitting a survey the web form does not populate attribute values for fields that are not relevant, but attributes for non-relevant questions will be populated with default values when using the IOS app.  (At least in the case of date/time fields with a default to now).  I prefer that values for fields that are not relevant remain blank or null.

Why are the behaviors not kept consistant?  And are there plans to bring the behaviors back together (to be the same)?

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Frequent Contributor II
5 Replies
Highlighted
Frequent Contributor II
Highlighted
New Contributor III

Is the bug resolved in the upcoming release?

Reply
0 Kudos
Highlighted
Frequent Contributor II

I do not see it in the list but I am not positive.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi Emeline,

Yes, BUG-000097105 related to default values and relevance has been fixed and will be available in upcoming 3.6 release. If you would like to test out the fix early you can install the 3.6 RC builds, which are available on EAC currently.

Phil.

Reply
0 Kudos
Highlighted
New Contributor III

Cool, thanks! That was quick. I should have some time to test tomorrow. I'll keep you posted!

Reply
0 Kudos