Inbox doesn't retrieve repeat records to edit

1971
9
Jump to solution
07-23-2019 12:04 PM
ANRGIS
by
Occasional Contributor

Hello,

I can't retrieve my repeat records from submitted surveys using the Inbox. I'm a little confused where I put the allowUpdates=true but I've tried adding it at the begin repeat (xlsFormType) in the bind::esri:parameters field and the Inbox settings using Connect; specifically the query expression. I found this help write-up to be a bit confusing for the Repeat section.

http://doc.arcgis.com/en/survey123/desktop/create-surveys/prepareforediting.htm

Clarification on what to do would be great! Thanks, Ryan

xls form attached

Tags (2)
0 Kudos
2 Solutions

Accepted Solutions
LubaHristova
Esri Contributor

Hi Ryan,

I just played around with the xls and as Philip mentioned the allowUpdates=true doesn't have to be on all of them just on begin and end. Can you try testing with this xls? When adding 'query' in bind parameters the inbox holds the repeat answers.

Let me know if this works. 

View solution in original post

Philip-Wilson
Esri Notable Contributor

Hi @GeomaticsPublisher,

It appears you are missing the "query" parameter in the bind::esri:parameters column. Without the "query" parameter the data in the related table is not queried and returned.

Please refer to: https://doc.arcgis.com/en/survey123/desktop/create-surveys/prepareforediting.htm#ESRI_SECTION1_80CFF...

Regards,

Phil.

View solution in original post

9 Replies
LubaHristova
Esri Contributor

Hi Ryan, 

I think I have seen this issue before. What version of Survey123 are you working with? There was a bug addressing this that was fixed in 3.2: BUG-000117987: Calculation fields fails to retain submitted values in Inbox if the fields are part of 'Repeats' which was fixed in 3.2

Can you apply these changes the excel and keep me updated if it works? 

Philip-Wilson
Esri Notable Contributor

Hi Ryan and Luba,

You only need to put the query and allowUpdates=true clause on the begin repeat question type in the bind::esri:parameters column. You do not need to put this on every question inside the repeat.

Also, for the Inbox settings in Connect, you only need to specify a where clause query if you only want to query a subset of the features in the layer. If you want all records, leave the where clause query blank, and just simply enable the Inbox.

This should be working as expected in the recent 3.5, if you are using 3.3 or an older version, this could be the problem. Also if you are still having issues, please provide a copy of your xlsx form survey, and also let us know if you are using AGO or Portal (what version) and what device/make/model/OS version you are using?

Phil.

ANRGIS
by
Occasional Contributor

Thanks for the clarification. I'm testing on iOS v3.5.164 (8 plus) and publishing the feature service to AGO using Connect v 3.5.157. I created a new survey just now and I'm still not able to retrieve the repeat records. I JUST have allowUpdates=true in the bind::esri:parameters column. What gives? Luba Hristova‌, I did try and populating all the repeat fields with allowUpdates=true and still didn't work  Survey attached. Thanks!

0 Kudos
LubaHristova
Esri Contributor

Hi Ryan,

I just played around with the xls and as Philip mentioned the allowUpdates=true doesn't have to be on all of them just on begin and end. Can you try testing with this xls? When adding 'query' in bind parameters the inbox holds the repeat answers.

Let me know if this works. 

ANRGIS
by
Occasional Contributor

Lesson learned...just put allowUpdates=true query in the bind::esri:parameters column for the beginning of the repeat and ALL your repeat data is retrieved from the Inbox.  Thanks Luba Hristova

Philip-Wilson
Esri Notable Contributor

Hi Ryan,

Yes, you need the query parameter at a minimum on the begin repeat to return any repeat records. Without the word query or a query='something' clause nothing is queried from the feature service and returned.

By default allowUpdates is false if not specified as a parameter, so only if you want the users to edit existing records in the repeat do you need to put allowUpdates=true. And the opposite applies for allowAdds. By default allowAdds is true if not specified, meaning new records can be added to the repeat, but if you want to limit the user so that new records can not be added, you can use allowAdds=false.

More info is here: https://doc.arcgis.com/en/survey123/desktop/create-surveys/prepareforediting.htm#ESRI_SECTION1_80CFF...

Phil.

DataOfficer
Regular Contributor

Hi @Philip-Wilson ,
We have query allowUpdates=true on our form repeats (under bind::esri:parameters) but the repeat data are not showing when accessed via the Inbox. The forms were created in Connect, and are being opened via Survey123 v3.12.277 on both Windows x64 desktop, and on an android phone. This worked previously. Any ideas?

Thanks,
Rob

0 Kudos
GeomaticsPublisher
New Contributor III

Hi,

I'm experiencing the same issues with allowUpdates=true on our form with repeats. I submit a form then go to the Inbox on my IPAD to make an edit to the submitted form and none of the details in the repeats are being pulled back to the form (they have originally been correctly saved to the related tables in the features service). 

I have allowUpdates=true in column X (bind::esriparamaters) on the begin repeat and end repeat lines as per the discussion above (this is now column X in the latest forms) but this does not appear to work??? any help much appreciated

GeomaticsPublisher_1-1635177791735.png

 

GeomaticsPublisher_0-1635177625653.png

 

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @GeomaticsPublisher,

It appears you are missing the "query" parameter in the bind::esri:parameters column. Without the "query" parameter the data in the related table is not queried and returned.

Please refer to: https://doc.arcgis.com/en/survey123/desktop/create-surveys/prepareforediting.htm#ESRI_SECTION1_80CFF...

Regards,

Phil.