Images for Choice Filtered Selection Questions

719
5
Jump to solution
12-19-2017 10:36 AM
NickDierks
New Contributor III

I'm trying to display images next a list of choices (as seen here and here). I'm able to get it to work just fine until I try to set it up as a cascading select. At that point, the choices appear to filter correctly, but no images (and sometimes no text either) will display, no matter what appearance I use.

These are the results of various combinations of attempts:

  • select_one, minimal, no choice filter
    • Image and text
  • select_one, compact, no choice filter
    • image, no text
  • select_one, any appearance, choice filter
    • no image, no text; just blank selection dots. The right number of them, though!
  • select_one_external, any appearance, choice filter
    • no image, just text

Is this a known limitation, or is there something I'm overlooking?

0 Kudos
1 Solution

Accepted Solutions
BrandonArmstrong
Esri Regular Contributor

Hi Nick,

As you mentioned, it appears that images that are referenced from the 'external_choices' sheet are not properly being reflected with the corresponding choice, when viewed using the Survey123 field app.  For the meantime, please do use the workaround of adding your cascading select options to the 'choices' sheet in your XLSForm.  I have gone ahead and made note of the issue on our end.

Thanks,

Brandon

View solution in original post

0 Kudos
5 Replies
BrandonArmstrong
Esri Regular Contributor

Hello Nick,

There should not be an issue displaying images in tandem with choices based off of a cascading select.  Are you seeing the same results in all clients? (Windows/Desktop field app, mobile field app, etc..)?  Can you attempt to download the attached example XLSForm and media folder and create a survey on your end using Survey123 Connect?

If it does not work on your end, we can explore reasons why that might be the case in your environment.  If it does work, please take a look at what may be different in your XLSForm compared to what is in the one attached.  Also, in that case, it may be helpful if you are able to upload your survey and media folder or send it to me in a private message.

Brandon

NickDierks
New Contributor III

Thanks for the reply! I tried the survey you attached and it worked fine as-is. I then modified it to mirror the setup in mine: combined all the pet choices into a single filtered list, and put them on an external_choices sheet. That external_choices seems to be the culprit, because now the survey (including the original unmodified fields) behaves exactly like mine, with missing images and/or text, including in the field app. I've attached this version here, and will PM you my regular survey to compare. I did test a copy of my survey where I took the list in question off of external_choices, and that worked. Not ideal, but works as a stopgap, I guess.

0 Kudos
BrandonArmstrong
Esri Regular Contributor

Hi Nick,

As you mentioned, it appears that images that are referenced from the 'external_choices' sheet are not properly being reflected with the corresponding choice, when viewed using the Survey123 field app.  For the meantime, please do use the workaround of adding your cascading select options to the 'choices' sheet in your XLSForm.  I have gone ahead and made note of the issue on our end.

Thanks,

Brandon

View solution in original post

0 Kudos
LorettaWinton1
New Contributor III

I am having the same issue. Is there any movement to rectify this?

Thanks,

Lori

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Loretta,

We have not yet resolved the issue.  As Brandon mentioned, this can be worked around by using the regular choice list.  An enhancement coming in 2.7 will make publishing surveys with long choice lists (too large for the web form processor to successfully convert) possible.

0 Kudos